Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519203 - Can't build mutter 3.26.2-1 from srpm, pipewire bug
Summary: Can't build mutter 3.26.2-1 from srpm, pipewire bug
Keywords:
Status: CLOSED DUPLICATE of bug 1519731
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 27
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 11:27 UTC by Robert Mader
Modified: 2017-12-01 10:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-01 10:45:07 UTC


Attachments (Terms of Use)

Description Robert Mader 2017-11-30 11:27:16 UTC
Description of problem:
When building mutter-3.26.2-1 from srpm, it fails to build. 3.26.1 works fine.

Version-Release number of selected component (if applicable):
3.26.2-1

How reproducible:
Tested on two distinct mashines

Steps to Reproduce:
1. install builddeps of mutter (dnf builddep mutter)
2. install srpm (rpm -ivh ./mutter-3.26.2-1.fc27.src.rpm)
3. prepare build: rpmbuild -bp SPECS/mutter.spec
4. try to build: rpmbuild -bb SPECS/mutter.spec

Actual results:

Fails with the following message:
In file included from /usr/include/spa/node.h:34:0,
                 from /usr/include/pipewire/port.h:31,
                 from /usr/include/pipewire/core.h:45,
                 from /usr/include/pipewire/client.h:47,
                 from /usr/include/pipewire/pipewire.h:29,
                 from backends/meta-screen-cast.c:27:
/usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
 #include <spa/pod-parser.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.

Expected results:
Builds fine

Additional info:
In a bug-report here (https://bugzilla.gnome.org/show_bug.cgi?id=790515), someone said it's a bug in pipewire

Comment 1 Robert Mader 2017-11-30 11:28:55 UTC
It was actually Florian Müller :)
But the bug is still not fixed in fedora 27

Comment 2 Robert Mader 2017-11-30 12:48:05 UTC
Alright, I'm sorry but the problem seems to be pipewire-devel-0.1.6-1.
It works fine with pipewire-devel-0.1.5-2


Nothing to do with mutter-3.26.2-1

But there's no updated version of pipewire-devel in updates-testing, so the problem persists for the time being.

Comment 3 Robert Mader 2017-12-01 10:45:07 UTC
I created a more appropriate bug here: https://bugzilla.redhat.com/show_bug.cgi?id=1519731

*** This bug has been marked as a duplicate of bug 1519731 ***


Note You need to log in before you can comment on or make changes to this bug.