Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519194 - ovirt-engine-rename should change ImageProxyAddress if hosted on same host as engine
Summary: ovirt-engine-rename should change ImageProxyAddress if hosted on same host as...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Tools.Rename
Version: 4.1.7.6
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.3.1
: ---
Assignee: Gal Zaidman
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 11:13 UTC by Jiri Belka
Modified: 2019-03-13 16:39 UTC (History)
6 users (show)

Fixed In Version: v1.5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-13 16:39:28 UTC
oVirt Team: Integration
rule-engine: ovirt-4.3+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 93442 master ABANDONED packaging: rename: Add name identifier to event 2018-08-15 11:42:32 UTC
oVirt gerrit 93443 master MERGED setup: plugins: Change ImageProxyAddress in engine's DB 2018-10-08 11:54:59 UTC

Description Jiri Belka 2017-11-30 11:13:45 UTC
Description of problem:

When IP/FQDN of engine is changed we use ovirt-engine-rename. But it does not change ImageProxyAddress even it is hosted on same engine host:

# select * from vdc_options where option_name ilike 'Image%' and option_value like '%example.com%';
 option_id |    option_name    |                  option_value                   | version 
-----------+-------------------+-------------------------------------------------+---------
       439 | ImageProxyAddress | 10-37-138-187.example.com:54323 | general
(1 row)

This still points to old IP.

# grep FQDN /etc/ovirt-engine/engine.conf.d/10-setup-protocols.conf
ENGINE_FQDN=10-37-138-131.example.com

rename tool or setup (??) should check if imageio-proxy is on same host as engine and if so, something should change ImageProxyAddress in engine's DB to same fqdn as engine's one.

Version-Release number of selected component (if applicable):
4.1.8

How reproducible:
100%

Steps to Reproduce:
1. engine with imageio-proxy on same host (default setup anyway)
2. change fqdn of the host
3. ovirt-engine-rename + engine-setup

Actual results:
check ImageProxyAddress in the engine db

Expected results:
ImageProxyAddress has old value

Additional info:

Comment 1 Sandro Bonazzola 2019-01-16 09:21:52 UTC
Gal, can you please check what's missing for closing this?

Comment 2 Petr Matyáš 2019-03-07 15:36:19 UTC
Verified on ovirt-engine-4.3.0-0.4.master.20190102130922.gitef7445b.el7.noarch

Comment 3 Sandro Bonazzola 2019-03-13 16:39:28 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.