Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519181 - After adding a PXE server, avaliable images are not listed in VM provisioning from the pxe.
Summary: After adding a PXE server, avaliable images are not listed in VM provisioning...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 10:49 UTC by Radim Hrazdil
Modified: 2017-12-15 15:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 14:18:43 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)
PXE server long after adding it, but before refresh (deleted)
2017-11-30 13:44 UTC, Jan Zmeskal
no flags Details
PXE server after refresh (deleted)
2017-11-30 13:45 UTC, Jan Zmeskal
no flags Details
Works as expected on CFME 5.8.2.3 (deleted)
2017-11-30 13:45 UTC, Jan Zmeskal
no flags Details

Description Radim Hrazdil 2017-11-30 10:49:27 UTC
Description of problem:
After adding pxe server to CFME, avaliable images are listed on the pxe server page. 

But then when I try to provision a new VM from the PXE server, there are no images listed for selection. 

Version-Release number of selected component (if applicable):
5.9.0.11.20171127204214_e316988
RHV 4.1.3.4-0.1.el7

How reproducible:
very

Steps to Reproduce:
1. Add PXE server
2. Go to Compute->infrastructure->Virtual Machines
3. Click rovision new VM
4. On Catalog tab, select Provision Type:PXE, then select the added PXE server

Actual results:
No images are listed for selection

Expected results:
There should be list of avaliable images from the pxe server, so some image can be selected

Additional info:

Comment 2 Jan Zmeskal 2017-11-30 13:43:45 UTC
Additional info:

Some screenshots attached. PXE images appear in the main window after refreshing relationship, which must be done manually. This should be done automatically after adding PXE server.

Even after that, PXE images are not displayed on the sidebar on left under the PXE server.

Also, PXE images added after refresh are not clickable, even though the cursor changes to a hand. They should be clickable.

Comment 3 Jan Zmeskal 2017-11-30 13:44:44 UTC
Created attachment 1360945 [details]
PXE server long after adding it, but before refresh

Comment 4 Jan Zmeskal 2017-11-30 13:45:05 UTC
Created attachment 1360946 [details]
PXE server after refresh

Comment 5 Jan Zmeskal 2017-11-30 13:45:43 UTC
Created attachment 1360948 [details]
Works as expected on CFME 5.8.2.3

Comment 7 Greg McCullough 2017-12-01 14:13:24 UTC
Radim - Did you follow the steps outlined in the PXE Provisioning section of the documentation?

https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.5/pdf/provisioning_virtual_machines_and_hosts/Red_Hat_CloudForms-4.5-Provisioning_Virtual_Machines_and_Hosts-en-US.pdf

See section 2.3. PXE PROVISIONING.

My guess is that steps "2.3.2. Creating System Image Types for PXE" and "2.3.3. Setting the PXE Image Type for a PXE Image" were skipped.

If this is not the case can you provide a link to the appliance with your configurations.

Comment 8 Radim Hrazdil 2017-12-05 14:18:43 UTC
Thank you Greg, this was indeed the problem. Closing as this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.