Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519162 - [RFE] No error message in UI after SSA fails
Summary: [RFE] No error message in UI after SSA fails
Keywords:
Status: NEW
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Oleg Barenboim
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 10:28 UTC by Jan Zmeskal
Modified: 2019-03-26 03:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Category: Feature
Cloudforms Team: CFME Core


Attachments (Terms of Use)
evm.log (deleted)
2017-11-30 10:28 UTC, Jan Zmeskal
no flags Details
Performing SSA on VM even thought CFME is not configured (deleted)
2017-11-30 10:33 UTC, Jan Zmeskal
no flags Details
Success message after ordering SSA (deleted)
2017-11-30 10:33 UTC, Jan Zmeskal
no flags Details

Description Jan Zmeskal 2017-11-30 10:28:24 UTC
Created attachment 1360808 [details]
evm.log

Description of problem:
When SSA fails, there is explicit information in evm.log. But there is no way how to tell when (or why) SSA failed from UI

Version-Release number of selected component (if applicable):
CFME 5.9.0.11.20171127204214_e316988
RHV 4.1.7.6

How reproducible:
100 %

Steps to Reproduce:
1. Have RHV provider with some VM. It must be configured in such a way that SSA cannot be successfully performed on the VM.
2. Go to Compute -> Infrastructure -> Virtual Machines
3. Check the VM, click Configuration -> Perform SmartState Analysis
4. You will get success flash message saying "Analysis initiated for 1 VM and Instance from the CFME Database"
5. Observe evm.log
6. You will get error message in evm.log. See line 80 of attached evm.log. That message is quite explicit in what went wrong.
7. Go back to CFME UI. Verify that there is no message saying that SSA was not performed successfully. 

Actual results:
No message shown in UI.

Expected results:
I expect to get error message after unsuccessful SSA explaining why it could not be performed.


Additional info:
Error message from evm.log:
[----] E, [2017-11-30T02:33:40.375265 #13184:8c7134] ERROR -- : Q-task_id([job_dispatcher]) MIQ(VmScan#process_abort) job aborting, No eligible proxies for VM :[/rhev/data-center/f9efd82c-e0a0-4486-9ba6-c4f7946591d9/mastersd/master/vms/b8c566d3-6ddd-4a2d-a1f6-5c1071be60d9/b8c566d3-6ddd-4a2d-a1f6-5c1071be60d9.ovf] - [VMs must be scanned from an EVM server whose host is attached to the same
  storage as the VM unless overridden via SmartProxy affinity.
  Please verify that:
  1) Direct LUNs are attached to ManageIQ appliance
  2) Management Relationship is set for the ManageIQ appliance], aborting job [a36723e5-be09-4744-a57d-9073e82c3f6d].

Comment 2 Jan Zmeskal 2017-11-30 10:33:11 UTC
Created attachment 1360821 [details]
Performing SSA on VM even thought CFME is not configured

Comment 3 Jan Zmeskal 2017-11-30 10:33:45 UTC
Created attachment 1360822 [details]
Success message after ordering SSA

Comment 4 Chris Pelland 2017-11-30 15:02:07 UTC
This works as designed.

RFE - SSA failures should go to the Notifications tab.


Note You need to log in before you can comment on or make changes to this bug.