Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519128 - Validator check-repo-availability.yaml generates a warning: "Consider using yum module rather than running yum"
Summary: Validator check-repo-availability.yaml generates a warning: "Consider using y...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ana Krivokapic
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks: 1559044
TreeView+ depends on / blocked
 
Reported: 2017-11-30 08:22 UTC by Udi
Modified: 2018-06-27 13:41 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-8.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1559044 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:40:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:00 UTC
OpenStack gerrit 515412 None master: MERGED tripleo-validations: Enhance repo validation to check for unwanted enabled repos (I70d88ca3a640003f213ad9df4d730e151cd0b... 2018-03-29 16:09:05 UTC

Description Udi 2017-11-30 08:22:55 UTC
Description of problem:
Validator check-repo-availability.yaml is running the 'yum' command directly, and the GUI user ends up seeing a warning instead of a successful result. When clicking on the validator to see the text of the warning, it turns out that it's just a recommendation to use the ansible yum module...


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-7.4.2-1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Run the validator: "Check availability of current repositories"


Actual results:
Warning


Expected results:
Success, without warnings


Additional info:
A similar bug was filed for the validator "Check if ceph-ansible is installed on the undercloud". There is already a fix for that bug. See bug #1516397 for details.

Comment 1 Gaël Chamoulaud 2017-12-07 14:22:34 UTC
Ana is actually working on improving this validation [1] and this issue will be fixed with her patch [1]

[1] - https://review.openstack.org/#/c/515412/

Comment 5 Udi 2018-04-24 07:40:24 UTC
Verified in: openstack-tripleo-validations-8.4.0-2.el7ost.noarch

Comment 7 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.