Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519124 - OVN add host (deploy) fails on RHV-H host and it becomes non-operational
Summary: OVN add host (deploy) fails on RHV-H host and it becomes non-operational
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 07:53 UTC by Mor
Modified: 2017-12-20 10:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:48:31 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
logs (deleted)
2017-11-30 07:53 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84937 master MERGED ansible: Do not enforce latest version of package 2017-11-30 20:11:42 UTC

Description Mor 2017-11-30 07:53:06 UTC
Created attachment 1360752 [details]
logs

Description of problem:
When trying to add RHV-H host on OVN enabled cluster, host deploy fails with error: "Host <HOST_FQDN> installation failed. Failed to execute Ansible host-deploy role. Please check logs for more details: /var/log/ovirt-engine/host-deploy/<filename>.log"

host-deploy log shows:
TASK [ovirt-provider-ovn-driver : Install ovirt-provider-ovn-driver] ***********
fatal: [orchid-vds2.qa.lab.tlv.redhat.com]: FAILED! => {"changed": false, "failed": true, "msg": "There are no enabled repos.\n Run \"yum repolist all\" to see the repos you have.\n To enable Red Hat Subscription Management repositories:\n     subscription-manager repos --enable <repo>\n To enable custom repositories:\n     yum-config-manager --enable <repo>\n", "rc": 1, "results": []}

Later on it becomes non-operational:
Host <HOST_FQDN> does not comply with the cluster <CLUSTER_NAME> networks, the following networks are missing on host: 'ovirtmgmt'.

Version-Release number of selected component (if applicable):
Red Hat Virtualization Host 4.2.0 (el7.4)
RHV engine 4.2.0-0.5.master.el7 (ships with ovirt-engine-4.2.0-0.5.master.el7.noarch)

How reproducible:
100%

Steps to Reproduce:
1. Try to add RHV-H host to engine.

Actual results:
Failure to add host. 
Host becomes non-operational.

Expected results:
On RHV-H ovirt-provider-ovn-driver is preinstalled, and there's no need to install it.

Additional info:

Comment 3 Mor 2017-11-30 13:07:44 UTC
Why did you close the bug as duplicate? rhe bug is about ovirt host deploy.

Comment 4 Mor 2017-11-30 13:32:27 UTC
Ryan, this bug is about skipping the installation of 'ovirt-provider-ovn-driver' if it's already installed on the host.

Comment 5 Ryan Barry 2017-11-30 13:37:04 UTC
Re-opening then.

ovirt-provider-ovn-driver is already on 4.2 RHVH images, though. Why is host-deploy trying to install it?

Comment 6 Dominik Holler 2017-11-30 13:47:03 UTC
The deployment is failing because it tried to ensure that the latest version of the package ovirt-provider-ovn-drive is installed. If there are no repos enabled, it is not possible to detect if it the latest version.

Comment 7 Michael Burman 2017-12-04 06:36:43 UTC
This report should be tested on the next 4.2 downstream build.

Comment 8 Michael Burman 2017-12-07 10:47:17 UTC
Verified on - 4.2.0-0.6.el7

Comment 9 Sandro Bonazzola 2017-12-20 10:48:31 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.