Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519103 - collector worker not able to capture metrics from Heketi Container
Summary: collector worker not able to capture metrics from Heketi Container
Keywords:
Status: CLOSED DUPLICATE of bug 1517676
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Ladislav Smola
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 06:48 UTC by Pradeep Kumar Surisetty
Modified: 2017-12-05 15:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 14:26:17 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pradeep Kumar Surisetty 2017-11-30 06:48:58 UTC
Description of problem:
------------------------

1) Setup OCP with CNS & Heketi container. 
2) Connect OCP &to CFME with Hawkular Metrics.
3) Enable C & U

OCP Setup:
---------

[root@gprfc031 ~]# oc get pods
NAME                                  READY     STATUS    RESTARTS   AGE
glusterblock-provisioner-dc-1-n9zgv   1/1       Running   1          18h
glusterfs-5p5xw                       1/1       Running   1          18h
glusterfs-fjfbc                       1/1       Running   1          18h
glusterfs-lrhlc                       1/1       Running   1          18h
heketi-1-jwr9m     

Messages: 
---------

[----] I, [2017-11-30T00:55:16.722229 #47104:eb1130]  INFO -- : MIQ(Container#just_perf_capture) [realtime] Capture for Container name: [heketi], id: [13], start_time: [2017-11-30 00:00:00 UTC]...
[----] I, [2017-11-30T00:55:16.725445 #47104:eb1130]  INFO -- : Exception in realtime_block :total_time - Timings: {:capture_state=>0.0020537376403808594, :total_time=>0.0030107498168945312}
[----] E, [2017-11-30T00:55:16.725779 #47104:eb1130] ERROR -- : MIQ(MiqQueue#deliver) Message id: [8664], Error: [uninitialized constant MetricsCapture]
[----] E, [2017-11-30T00:55:16.726010 #47104:eb1130] ERROR -- : [NameError]: uninitialized constant MetricsCapture  Method:[block in method_missing]
[----] E, [2017-11-30T00:55:16.726090 #47104:eb1130] ERROR -- : /var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:3:in `perf_capture_object'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:6:in `perf_collect_metrics'


 while trying to capture for container heketi:  
-----------------------------------------------

[----] I, [2017-11-30T01:13:17.532020 #47112:eb1130]  INFO -- : MIQ(Container#just_perf_capture) [realtime] Capture for Container name: [heketi], id: [13], start_time: [2017-11-30 00:00:00 UTC]...


[----] I, [2017-11-30T01:13:17.535150 #47112:eb1130]  INFO -- : Exception in realtime_block :total_time - Timings: {:capture_state=>0.0020852088928222656, :total_time=>0.002958536148071289}

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

C & U fails. 

Expected results:

C & U should work

Additional info:

Comment 3 Ladislav Smola 2017-11-30 14:26:17 UTC

*** This bug has been marked as a duplicate of bug 1517676 ***


Note You need to log in before you can comment on or make changes to this bug.