Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519087 - Clicking Show Guide in Scap Policies gives 500 Internal Server Error
Summary: Clicking Show Guide in Scap Policies gives 500 Internal Server Error
Keywords:
Status: CLOSED DUPLICATE of bug 1513326
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard: scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 06:00 UTC by sbadhwar
Modified: 2017-11-30 12:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 12:31:54 UTC


Attachments (Terms of Use)
Foreman Production log (deleted)
2017-11-30 06:00 UTC, sbadhwar
no flags Details

Description sbadhwar 2017-11-30 06:00:50 UTC
Created attachment 1360683 [details]
Foreman Production log

Description of problem:
So, I downloaded a SCAP datastream from https://www.redhat.com/security/data/metrics/ds/com.redhat.rhsa-all.ds.xml

and added the data stream as SCAP content in Satellite.
After the Content was added, I went ahead with creating the policy for the SCAP.

Now, whenever I click Show Guide under Scap Policies, Satellite is giving 500: Internal Server Error


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Upload a new datastream under SCAP content
2. Add a new policy using the newly added SCAP content
3. Once the policy has been added, click on show guide

Actual results:
500 Internal Server Error

Comment 1 Marek Hulan 2017-11-30 12:31:54 UTC
Yet another duplicate of BZ 1513326, most likely you need newer openscap version. Openscap package comes from RHEL and we have no way to fix it on our side. Please look at original BZ for more details. Searching for duplicates prior opening new bugs is appreciated.

*** This bug has been marked as a duplicate of bug 1513326 ***


Note You need to log in before you can comment on or make changes to this bug.