Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519060 - OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was removed within upgrade playbook run
Summary: OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was removed withi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.9.0
Assignee: Kenny Woodson
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 02:17 UTC by Takayoshi Kimura
Modified: 2018-10-18 09:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The upgrade playbooks previously did not regenerate the registry certificate when upgrading from releases prior to 3.6 which lacked the name 'docker-registry.default.svc'. As such the configuration variables were not updated to push to the registry via DNS. The 3.9 upgrade playbooks now regenerate the certificate when needed ensuring that all environments upgraded to 3.9 now push to the registry via DNS.
Clone Of:
Environment:
Last Closed: 2018-03-28 14:14:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:14:59 UTC

Description Takayoshi Kimura 2017-11-30 02:17:19 UTC
Description of problem:

OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was removed within upgrade playbook run.

Version-Release number of the following components:

$ rpm -q openshift-ansible
openshift-ansible-3.6.173.0.75-1.git.0.0a44128.el7.noarch
$ rpm -q ansible
ansible-2.4.1.0-1.el7.noarch
$ ansible --version
ansible 2.4.1.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/home/nekop/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:

> $ sudo diff /etc/sysconfig/atomic-openshift-master.61444.2017-11-30@09:57:34~ /etc/sysconfig/atomic-openshift-master
> 8d7
> < OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000

Expected results:

No changes in /etc/sysconfig/atomic-openshift-master

Additional info:

Similar issue is reported in https://bugzilla.redhat.com/show_bug.cgi?id=1467786  , this test is using latest packages which has the fix.

Comment 9 liujia 2018-02-05 08:23:38 UTC
Reproduced on v3.6.173.0.75
1. Fresh install ocp v3.6.173.0.21, sti-build succeed with pushing images docker-registry.default.svc:5000.
2. Upgrade v3.6.173.0.21 to v3.6.173.0.75.
3. Check sti-build succeed with push images 
# diff atomic-openshift-master.1143.2018-02-05@01:40:44~ atomic-openshift-master
1c1
< OPTIONS=--loglevel=5
---
> OPTIONS=--loglevel=2
3d2
< OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000

Comment 10 liujia 2018-02-05 08:36:02 UTC
Reproduced on openshift-ansible-3.9.0-0.31.0.git.0.e0a0ad8.el7.noarch.

# diff atomic-openshift-master-api.1872.2018-02-04@21\:55\:29~ atomic-openshift-master-api
3d2
< OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000

# diff atomic-openshift-master-controllers.2085.2018-02-04@21\:55\:30~ atomic-openshift-master-controllers
3d2
< OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000

Comment 11 liujia 2018-02-05 08:37:08 UTC
Blocked verify by 1540464

Comment 12 liujia 2018-02-07 07:54:24 UTC
Verified on openshift-ansible-3.9.0-0.38.0.git.0.57e1184.el7.noarch

Comment 13 liujia 2018-02-07 07:55:27 UTC
Add case ocp-17955

Comment 16 errata-xmlrpc 2018-03-28 14:14:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.