Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518990 - Dialog values not available in root or object
Summary: Dialog values not available in root or object
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Beta 3
: 5.9.0
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 22:27 UTC by Jeffrey Cutter
Modified: 2018-03-06 15:10 UTC (History)
7 users (show)

Fixed In Version: 5.9.0.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 15:10:11 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Jeffrey Cutter 2017-11-29 22:27:46 UTC
Description of problem:

Service dialog values for element names are not available in $evm.root or $evm.object.


Version-Release number of selected component (if applicable):

5.9.0.11.20171127204214_e316988

How reproducible:

Every time.

Steps to Reproduce:
1.  Create a service dialog with a couple elements and at least one dynamic element.  Have the elements refresh the other elements.
2.  In the dynamic element method, dump the root and object attributes.
3.  Create a catalog item that uses the service dialog.
4.  Tail the automation.log on the appliance.
5.  Order the catalog item and enter some data and review the contents of $evm.root and $evm.object as dumped into the automation.log by the dynamic method noting no dialog_* attributes.

Comment 3 eclarizi 2017-11-30 15:46:02 UTC
I believe the root cause is similar to https://bugzilla.redhat.com/show_bug.cgi?id=1518390 and I should have a PR out shortly for this that will combine with Jillian's API PR.

Comment 4 Shveta 2018-01-29 23:49:43 UTC
Logs shows dialog values in root .
Verified in 5.9.0.18.20180125190915_e0d3417


Note You need to log in before you can comment on or make changes to this bug.