Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518934 - Normal Operating Ranges shows 0 values instead of 'Not Available'
Summary: Normal Operating Ranges shows 0 values instead of 'Not Available'
Keywords:
Status: ASSIGNED
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Levente Berky
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 19:47 UTC by Tasos Papaioannou
Modified: 2019-03-25 03:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tasos Papaioannou 2017-11-29 19:47:38 UTC
Description of problem:

For a VM that doesn't have any daily metric rollups, the Max value for CPU, CPU Usage, Memory, or Memory Usage displays as 'Not Available', but the High, Average, and Low values all display as zero values. For example:

CPU 	  	 
Max 	Not Available
High 	0 MHz
Average 0 MHz
Low 	0 MHz

They should be consistent, and show Not Available.

Version-Release number of selected component (if applicable):

5.9.0.11

How reproducible:

100%

Steps to Reproduce:
1.) Add an infrastructure provider with existing VM's, without enabling C&U.
2.) View a VM's summary page.

Actual results:

Inconsistent usage of 'Not Available' vs. 0 MHz / 0 Bytes / 0.00% for Max vs. High, Average, and Low fields.

Expected results:

All fields show 'Not Available'.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.