Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518860 - python-itsdangerous is failing to install for ppc64 builds
Summary: python-itsdangerous is failing to install for ppc64 builds
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: ppc64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 16:26 UTC by Brian Lane
Modified: 2017-12-01 10:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-01 10:25:34 UTC


Attachments (Terms of Use)
python-itsdangerous installation error on ppc64le (deleted)
2017-12-01 09:53 UTC, clime
no flags Details
epel-7-ppc64le mock config (deleted)
2017-12-01 09:57 UTC, clime
no flags Details

Description Brian Lane 2017-11-29 16:26:23 UTC
Description of problem:
Building a package results in this (on pppc64, x86_64 was successful):

https://copr-be.cloud.fedoraproject.org/results/@weldr/lorax-composer/epel-7-ppc64le/00681863-lorax/builder-live.log

Looked at centos, but they say all is ok (and I can wget the file just fine locally): 

https://bugs.centos.org/view.php?id=14101

This has been happening for at least a week. My last 2 builds have failed for ppc64 because of the same error.

python-itsdangerous-0.23-2.el7 FAILED                                          
http://mirror.centos.org/altarch/7/extras/ppc64le/Packages/python-itsdangerous-0.23-2.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=extras clean metadata and try again
Trying other mirror.

Comment 1 clime 2017-12-01 09:53:47 UTC
Created attachment 1361485 [details]
python-itsdangerous installation error on ppc64le

Comment 2 clime 2017-12-01 09:55:47 UTC
I don't think this is an error in COPR. 

$  mock -r epel-7-ppc64le install python-itsdangerous

gives exactly the same error with default epel-7-ppc64le config (will attach as well).

Comment 3 clime 2017-12-01 09:57:40 UTC
Created attachment 1361486 [details]
epel-7-ppc64le mock config

Comment 4 clime 2017-12-01 10:25:34 UTC
And I got the same error in a CentOS7 ppc64le container.

The reason is wrong checksum on the python-itsdangerous package:

In the repodata here: http://mirror.centos.org/altarch/7/extras/ppc64le/repodata/
its:

1e6fece616e3e499a58532d761265e0f6f5d7f914cee059416be09ca2f44bf69

but if you try to download a file and run # sha256sum python-itsdangerous-0.23-2.el7.noarch.rpm, you get:

5500f01a9811f8fe16bd03ff308488d0d578e7841772f2115ac06c4660f7f420

so what is downloaded does not match what is reported by repodata.

I will close this and update https://bugs.centos.org/view.php?id=14101
with this information.

Comment 5 clime 2017-12-01 10:31:25 UTC
Could not update the CentOS so at least posted the info here: http://centosfaq.org/centos/is-centos-extras-repo-broken/


Note You need to log in before you can comment on or make changes to this bug.