Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518857 - atomic pull unable to find image by shortname from registry.access.redhat.com
Summary: atomic pull unable to find image by shortname from registry.access.redhat.com
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1518866
TreeView+ depends on / blocked
 
Reported: 2017-11-29 16:23 UTC by Michael Nguyen
Modified: 2018-09-26 07:47 UTC (History)
6 users (show)

Fixed In Version: atomic-1.20.1-6.git436cf5d.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518866 (view as bug list)
Environment:
Last Closed: 2018-09-26 07:47:53 UTC


Attachments (Terms of Use)

Description Michael Nguyen 2017-11-29 16:23:32 UTC
Description of problem:
atomic pull is unable to find images by shortname from registry.access.redhat.com.  Short name works for docker.io registry.

Version-Release number of selected component (if applicable):
[cloud-user@rhelah ~]$ sudo rpm -qa atomic
atomic-1.20.1-3.git840732d.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. atomic pull rhel7/cockpit-ws

Actual results:
Unable to find rhel7/cockpit-ws

Expected results:
Successful pull of cockpit container from redhat registry

Additional info:
[cloud-user@rhelah ~]$ sudo atomic --debug pull rhel7/cockpit-ws
Namespace(_class=<class 'Atomic.pull.Pull'>, assumeyes=False, debug=True, func='pull_image', ignore=False, image='rhel7/cockpit-ws', profile=False, reg_type=None, src_creds=None, storage=None)
Unable to find rhel7/cockpit-ws
Traceback (most recent call last):
  File "/bin/atomic", line 185, in <module>
    sys.exit(_func())
  File "/usr/lib/python2.7/site-packages/Atomic/pull.py", line 54, in pull_image
    remote_image_obj = be.make_remote_image(self.args.image)
  File "/usr/lib/python2.7/site-packages/Atomic/backends/_docker.py", line 270, in make_remote_image
    img_obj = self._make_remote_image(image)
  File "/usr/lib/python2.7/site-packages/Atomic/backends/_docker.py", line 275, in _make_remote_image
    return self._make_image(image, None, remote=True)
  File "/usr/lib/python2.7/site-packages/Atomic/backends/_docker.py", line 180, in _make_image
    img_obj = Image(image, remote=remote)
  File "/usr/lib/python2.7/site-packages/Atomic/objects/image.py", line 54, in __init__
    self._instantiate()
  File "/usr/lib/python2.7/site-packages/Atomic/objects/image.py", line 81, in _instantiate
    self._setup_common()
  File "/usr/lib/python2.7/site-packages/Atomic/objects/image.py", line 89, in _setup_common
    self.registry, self.repo, self.image, self.tag, self.digest = Decompose(self.fq_name).all
  File "/usr/lib/python2.7/site-packages/Atomic/objects/image.py", line 127, in fq_name
    self._fq_name = ri.find_image_on_registry(quiet=True)
  File "/usr/lib/python2.7/site-packages/Atomic/discovery.py", line 96, in find_image_on_registry
    raise RegistryInspectError("Unable to find {}".format(self.orig_input))
[cloud-user@rhelah ~]$ sudo atomic pull registry.access.redhat.com/rhel7/cockpit-ws
Pulling registry.access.redhat.com/rhel7/cockpit-ws:latest ...
Copying blob sha256:76b0264c130a031b05e695bf175147575b93271c9c838408ba63daaa7de934e9
 71.39 MB / ? [------------------------------------=----------------------] 18s 
Copying blob sha256:26dc84c55415d3296f5faef853d2ff7a5da199b6fd26ba0f942da7285ee7e88d
 1.21 KB / ? [=------------------------------------------------------------] 0s 
Copying blob sha256:efab21e2dc5212eb31353fae61163ab5c49217cc22eb43f30dff53f181542844
 5.68 MB / ? [--------------------------------------------------=----------] 1s 
Copying config sha256:05b111552fb3303741f6893add30443a5091f1640ba08bb26714e656436a8159
 6.23 KB / 6.23 KB [========================================================] 0s
Writing manifest to image destination
Storing signatures
[cloud-user@rhelah ~]$ sudo atomic images list
   REPOSITORY                                    TAG      IMAGE ID       CREATED            VIRTUAL SIZE   TYPE      
   registry.access.redhat.com/rhel7/cockpit-ws   latest   05b111552fb3   2017-10-12 09:34   213.17 MB      docker    
[cloud-user@rhelah ~]$ sudo atomic pull busybox
Pulling docker.io/library/busybox:latest ...
Copying blob sha256:0ffadd58f2a61468f527cc4f0fc45272ee4a1a428abe014546c89de2aa6a0eb5
 698.53 KB / 698.53 KB [====================================================] 0s
Copying config sha256:6ad733544a6317992a6fac4eb19fe1df577d4dec7529efec28a5bd0edad0fd30
 1.46 KB / 1.46 KB [========================================================] 0s
Writing manifest to image destination
Storing signatures
[cloud-user@rhelah ~]$ sudo atomic images list
   REPOSITORY                                    TAG      IMAGE ID       CREATED            VIRTUAL SIZE   TYPE      
   docker.io/busybox                             latest   6ad733544a63   2017-11-03 22:39   1.13 MB        docker    
   registry.access.redhat.com/rhel7/cockpit-ws   latest   05b111552fb3   2017-10-12 09:34   213.17 MB      docker    

[cloud-user@rhelah ~]$ cat /etc/containers/registries.conf 
# This is a system-wide configuration file used to
# keep track of registries for various container backends.
# It adheres to TOML format and does not support recursive
# lists of registries.

# The default location for this configuration file is /etc/containers/registries.conf.

# The only valid categories are: 'registries.search', 'registries.insecure', 
# and 'registries.block'.

[registries.search]
registries = ['registry.access.redhat.com']

# If you need to access insecure registries, add the registry's fully-qualified name.
# An insecure registry is one that does not have a valid SSL certificate or only does HTTP.
[registries.insecure]
registries = []


# If you need to block pull access from a registry, uncomment the section below
# and add the registries fully-qualified name.
#
# Docker only
[registries.block]
registries = []


[cloud-user@rhelah ~]$ sudo rpm-ostree status
State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.4.3 (2017-11-28 16:49:56)
                    Commit: 13fe9e86d640fd257afe831e4b33ad1eb6183d7de2a550dc7397a7b4b1f6ef25
              GPGSignature: Valid signature by 567E347AD0044ADE55BA8A5F199E2F91FD431D51

Comment 5 Edward Shen 2018-09-10 11:44:14 UTC
verified on atomic-1.22.1-25.git5a342e3.el7.x86_64.

Comment 7 errata-xmlrpc 2018-09-26 07:47:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2795


Note You need to log in before you can comment on or make changes to this bug.