Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518849 - Provisioning from OpenStack Volumes Fails during Verify State with error: [NoMethodError]: undefined method `id' for nil:NilClass Method:[block in method_missing]
Summary: Provisioning from OpenStack Volumes Fails during Verify State with error: [No...
Keywords:
Status: CLOSED DUPLICATE of bug 1518381
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: cfme-future
Assignee: Marek Aufart
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 16:15 UTC by Loic Avenel
Modified: 2017-12-18 14:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 11:48:11 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)
evm.log (deleted)
2017-11-29 16:19 UTC, Loic Avenel
no flags Details

Description Loic Avenel 2017-11-29 16:15:52 UTC
Description of problem: Provisioning from OpenStack Volumes Fails during Verify State with error: [NoMethodError]: undefined method `id' for nil:NilClass  Method:[block in method_missing]


Version-Release number of selected component (if applicable): 5.9.0.11


How reproducible: always


Steps to Reproduce:
1. Provision a VM from Volume in OpenStack
2. 
3.

Actual results: VM Created but verify state fails


Expected results: should work


Additional info:
[----] E, [2017-11-29T07:58:14.397640 #21168:1231134] ERROR -- : Q-task_id([miq_provision_53]) [NoMethodError]: undefined method `id' for nil:NilClass  Method:[block in method_missing]
[----] E, [2017-11-29T07:58:14.397757 #21168:1231134] ERROR -- : Q-task_id([miq_provision_53]) /var/www/miq/vmdb/app/models/manageiq/providers/cloud_manager/provision/cloning.rb:3:in `find_destination_in_vmdb'
/var/www/miq/vmdb/app/models/miq_provision/state_machine.rb:47:in `poll_destination_in_vmdb'
/var/www/miq/vmdb/app/models/miq_queue.rb:449:in `block in dispatch_method'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:448:in `dispatch_method'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `block in deliver'
/var/www/miq/vmdb/app/models/user.rb:253:in `with_user_group'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:104:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:152:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:329:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:326:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:326:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:127:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:22:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:357:in `block in start_runner_via_fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:355:in `start_runner_via_fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:349:in `start_runner'
/var/www/miq/vmdb/app/models/miq_worker.rb:396:in `start'
/var/www/miq/vmdb/app/models/miq_worker.rb:266:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `times'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:53:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `each'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server.rb:141:in `start'
/var/www/miq/vmdb/app/models/miq_server.rb:233:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:27:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:48:in `start'
/var/www/miq/vmdb/lib/workers/bin/evm_server.rb:4:in `<main>'
[----] E, [2017-11-29T07:58:26.431684 #21160:1231134] ERROR -- : Q-task_id([miq_provision_53]) MIQ(MiqAeEngine.deliver) Error delivering {"request"=>"vm_provision"} for object [ManageIQ::Providers::Openstack::CloudManager::Provision.53] with state [CheckProvisioned] to Automate:

Comment 2 Loic Avenel 2017-11-29 16:19:31 UTC
Created attachment 1360434 [details]
evm.log

Comment 3 Dave Johnson 2017-11-29 16:44:29 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 4 Ladislav Smola 2017-11-30 11:48:11 UTC

*** This bug has been marked as a duplicate of bug 1518381 ***


Note You need to log in before you can comment on or make changes to this bug.