Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518833 - API: Post create action is not working with services subcollection generic object
Summary: API: Post create action is not working with services subcollection generic ob...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard: :api:generic_object
Depends On:
Blocks: 1525049
TreeView+ depends on / blocked
 
Reported: 2017-11-29 15:53 UTC by Anurag
Modified: 2018-06-21 20:28 UTC (History)
5 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1525049 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:28:46 UTC
Category: Bug
Cloudforms Team: CFME Core
ansinha: automate_bug+


Attachments (Terms of Use)

Comment 2 Jillian Tullo 2017-12-11 20:28:02 UTC
Just as an additional note in addition to the pull request, to clarify this issue, the issue is that the create action should not be supported on this subcollection. The actions being returned were invalid.

Comment 3 CFME Bot 2017-12-11 20:55:09 UTC
New commit detected on ManageIQ/manageiq-api/master:
https://github.com/ManageIQ/manageiq-api/commit/7b13b36d68afc1560b493e9f63f43d421a4abc4a

commit 7b13b36d68afc1560b493e9f63f43d421a4abc4a
Author:     Jillian Tullo <jtullo@redhat.com>
AuthorDate: Mon Dec 11 14:45:43 2017 -0500
Commit:     Jillian Tullo <jtullo@redhat.com>
CommitDate: Mon Dec 11 14:56:00 2017 -0500

    Return correct subcollection actions
    
    Right now, sub collection actions that are specified on a specific collection (i.e., :generic_object_subcollection_actions: specified on :services: collection) are not taking precedence to those sub collection actions defined on the collection itself (i.e. :subcollection_actions: defined under :generic_objects:). This is causing incorrect actions to be returned, causing the users to believe that they have actions that they do not, such as :create: for the generic objects sub collection on services.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1518833

 app/controllers/api/base_controller/renderer.rb | 2 +-
 spec/requests/services_spec.rb                  | 9 +++++++++
 2 files changed, 10 insertions(+), 1 deletion(-)


Note You need to log in before you can comment on or make changes to this bug.