Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518806 - logging-es-data-master DC images using "v3.7" tag instead of using openshift_image_tag
Summary: logging-es-data-master DC images using "v3.7" tag instead of using openshift_...
Keywords:
Status: CLOSED DUPLICATE of bug 1530183
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 15:16 UTC by Justin Pierce
Modified: 2018-01-17 14:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 14:44:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1516564 None None None Never

Internal Links: 1516564

Description Justin Pierce 2017-11-29 15:16:35 UTC
Description of problem:
Installed v3.7.9 (~GA) and found that logging/logging-es-data-master-* DCs were all using a "v3.7" tag instead of the value of openshift_image_tag ("v3.7.9" set in our inventory).

Version-Release number of selected component (if applicable):
v3.7.9

How reproducible:
100% . Seems to be by design. 

From openshift-ansible/roles/openshift_logging_elasticsearch/vars/openshift-enterprise.yml:
__openshift_logging_elasticsearch_image_version: "{{ openshift_logging_image_version | default ('v3.7') }}"
__openshift_logging_elasticsearch_proxy_image_prefix: "{{ openshift_logging_image_prefix | default('registry.access.redhat.com/openshift3/') }}"
__openshift_logging_elasticsearch_proxy_image_version: "{{ openshift_logging_image_version | default ('v3.7') }}"


Expected results:
openshift_image_tag should provide a basis for all OCP component image versions.


Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2017-11-29 15:20:44 UTC
Linked a related bug, if we're 100% certain that openshift_image_tag will always exist for all the images I think it's fine to default everything to using that image tag.

This would then mean that they'd unless they override the values they'll only ever run a version matched to the master though. Do we want that?

Comment 2 Justin Pierce 2017-11-29 18:23:58 UTC
I think it makes sense for any component considered "core"  -- which logging effectively is now. Without a pretty broad default, we might find ourselves regularly discovering new components that need inventory changes. That process of discovery is going to be very error prone since it is extremely easy (as in this case) for it to go undetected.

Comment 3 Vadim Rutkovsky 2018-01-17 13:56:52 UTC
Sounds like its another duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1530183

Comment 4 Scott Dodson 2018-01-17 14:44:36 UTC
Yeah, same general problem.

*** This bug has been marked as a duplicate of bug 1530183 ***


Note You need to log in before you can comment on or make changes to this bug.