Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518752 - Unable to provision a VM on RHV 4.1 provider with "Unable to find specified profile: <rhevm>" when no Network is selected
Summary: Unable to provision a VM on RHV 4.1 provider with "Unable to find specified p...
Keywords:
Status: CLOSED DUPLICATE of bug 1525258
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Martin Perina
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 14:44 UTC by Antonin Pagac
Modified: 2018-06-26 22:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 12:43:00 UTC
Category: ---
Cloudforms Team: RHEVM


Attachments (Terms of Use)
evm.log (deleted)
2017-11-29 14:44 UTC, Antonin Pagac
no flags Details

Description Antonin Pagac 2017-11-29 14:44:53 UTC
Created attachment 1360378 [details]
evm.log

Description of problem:
When trying to provision a VM on RHV 4.1.5.2 and not selecting any network, there is an error in the UI and also in evm.log. From the log:

"[----] E, [2017-11-29T07:42:26.122047 #13212:4e7140] ERROR -- : Q-task_id([miq_provision_10]) MIQ(ManageIQ::Providers::Redhat::InfraManager::Provision#provision_error) [[MiqException::MiqProvisionError]: Unable to find specified profile: <rhevm>] encountered during phase [customize_destination]"

and also:

"[----] E, [2017-11-29T07:42:31.244273 #13221:4e7140] ERROR -- : Q-task_id([miq_provision_10]) MIQ(MiqAeEngine.deliver) Error delivering {"request"=>"vm_provision"} for object [ManageIQ::Providers::Redhat::InfraManager::Provision.10] with state [CheckProvisioned] to Automate:"

The provisioning request fails. The VM is created on RHV provider but it never gets started. Occurs when provisioning a VM via Lifecycle and also when ordering a service via SSUI.
The option to power on the VM right after creation was checked.


Version-Release number of selected component (if applicable):
Version 5.9.0.11.20171127204214_e316988

How reproducible:
Always

Steps to Reproduce:
1. Have an appliance with RHV 4.1 added
2. Navigate to Compute -> Infrastructure -> Virtual Machines
3. Lifecycle -> Provision VMs
4. Fill out every required option but leave the Network value "<None>"
5. Submit the request, no error or warning appears
5. Wait a bit

Actual results:
Error appears in the ui and in the evm.log; VM is created on provider but never powered ON.

Expected results:
VM provisioned and powered on; in case the Network option is required, user should be notified

Additional info:
Adding evm.log

Provisioning on RHV 4.1 works fine when appropriate network is selected.

Comment 2 Ilanit Stein 2018-06-20 12:43:00 UTC
This bug is a duplicate of bug 1525258, 
that was fixed & verified on CFME-5.9.0.12/RHV-4.1.8

*** This bug has been marked as a duplicate of bug 1525258 ***


Note You need to log in before you can comment on or make changes to this bug.