Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518739 - VMs & Templates->RHV provider->Datacenter contain only newly added template/VM
Summary: VMs & Templates->RHV provider->Datacenter contain only newly added template/VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Piotr Kliczewski
QA Contact: Ilanit Stein
URL:
Whiteboard: rhev:target refresh
Depends On:
Blocks: 1526042
TreeView+ depends on / blocked
 
Reported: 2017-11-29 14:27 UTC by Ilanit Stein
Modified: 2018-06-21 20:54 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1526042 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:54:34 UTC
Category: Bug
Cloudforms Team: RHEVM


Attachments (Terms of Use)
evm.log (deleted)
2017-11-29 14:30 UTC, Ilanit Stein
no flags Details
automation.log (deleted)
2017-11-29 14:32 UTC, Ilanit Stein
no flags Details
VMs_and_Templates_under_datacenter.png (deleted)
2017-11-29 14:35 UTC, Ilanit Stein
no flags Details
VMs_and_Templates_under_rhv_provider.png (deleted)
2017-11-29 14:35 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq pull 16618 None None None 2017-12-08 09:24:54 UTC

Description Ilanit Stein 2017-11-29 14:27:23 UTC
Description of problem:
Have a CFME with RHV provider connected,
On RHv side, create a template from a VM, and then create a VM from this template.
Check on CFME Compute->Infra->VMs & Templates: RHV provider name->Datacenter:
In the main window, only the new Template & VM created are displayed.
Even after 1/2 and hour, this same display remain.

Version-Release number of selected component (if applicable):
CFME-5.9.0.10/RHV-4.1.7

Expected results:
All VMs and Templates under the RHV provider Datacenter should be displayed.

Additional info:
This bug might be related to Bug 1517852 - Target refresh of template, further to Add template from VM is not fully populated

Comment 3 Ilanit Stein 2017-11-29 14:30:36 UTC
Created attachment 1360361 [details]
evm.log

Comment 4 Ilanit Stein 2017-11-29 14:32:16 UTC
Comment on attachment 1360361 [details]
evm.log

See template "rhv_sealed_temp", and VM "vm_from_rhv_sealed_temp" newly created.

Comment 5 Ilanit Stein 2017-11-29 14:32:38 UTC
Created attachment 1360362 [details]
automation.log

Comment 6 Ilanit Stein 2017-11-29 14:35:03 UTC
Created attachment 1360363 [details]
VMs_and_Templates_under_datacenter.png

Comment 7 Ilanit Stein 2017-11-29 14:35:30 UTC
Created attachment 1360364 [details]
VMs_and_Templates_under_rhv_provider.png

Comment 8 Piotr Kliczewski 2017-11-30 08:09:15 UTC
Is there the same behavior for regular refresh?

Comment 9 Ilanit Stein 2017-11-30 08:24:49 UTC
Observing the same CFME, a day after, now show all VMs and templates, under the datacenter.
Probably automatic full refresh, brought the correct data.

Comment 10 Ilanit Stein 2017-12-03 07:06:20 UTC
Some emphasis: This bug is not related to graph refresh. Graph refresh is OFF, by default, on CFME-5.9.0.10, and it was not turned ON.

Comment 11 Piotr Kliczewski 2017-12-04 09:53:11 UTC
I tested this on master and I was not able to reproduce it with regular refresh but with graph refresh. Please specify the steps to reproduce if you used regular.

Comment 12 Ilanit Stein 2017-12-04 14:52:31 UTC
1. Have a CFME with RHV provider connected.
2. On RHV side, create a template from a RHEL down VM, including seal template.
3. On RHV side, create a VM from this template.
4. Run this VM.
5. On CFME go to Compute->Infrastracture->VMs & Templates: 
RHV provider name->Datacenter:

In the main window, only the newly created single Template & single VM are displayed.

Comment 14 CFME Bot 2017-12-12 21:22:10 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/89b617da44d0a01d5e26cd4387c325be5fb4dcb5

commit 89b617da44d0a01d5e26cd4387c325be5fb4dcb5
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Thu Dec 7 16:44:34 2017 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Tue Dec 12 17:10:50 2017 +0100

    disconnect flag not respected in link_ems_inventory
    
    When new vm is created we use `save_ems_inventory_no_disconnect` where
    we set disconnect flag to `false`. It was not respected for all
    operations.
    
    Bug-Url:
    https://bugzilla.redhat.com/1518739

 app/models/ems_refresh/link_inventory.rb       |  4 +-
 spec/models/ems_refresh/save_inventory_spec.rb | 97 ++++++++++++++++++++++++++
 2 files changed, 99 insertions(+), 2 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.