Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518733 - Unnecessary attempt to migrate VM set with AutoResume option in case of I/O Error
Summary: Unnecessary attempt to migrate VM set with AutoResume option in case of I/O E...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 14:14 UTC by Polina
Modified: 2017-11-29 15:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 15:01:00 UTC
oVirt Team: Virt


Attachments (Terms of Use)
logs and screenshot (deleted)
2017-11-29 14:14 UTC, Polina
no flags Details

Description Polina 2017-11-29 14:14:48 UTC
Created attachment 1360356 [details]
logs and screenshot

Description of problem:
A VM with AutoResume option set in case of I/O Error must just be Paused and then Resumed after the storage is returned.

Version-Release number of selected component (if applicable):
rhvm-4.2.0-0.5.master.el7.noarch

How reproducible:100%


Steps to Reproduce:
1.create VM , windows OS , scsi storage domain. Run. 
2.Block all the storages on the host (scsi and nfs - the bug doesn't happen if only scsi is blocked)
3.The VM is Paused(it is ok and expected). Then unexpectedly the VM tries to migrate (unsuccessfully) bringing failure task and also error in engine log

Actual results: the failed event task - Migrating VM windows_10_new_israel. and also "ERROR [org.ovirt.engine.core.bll.SetNonOperationalVdsCommand] (EE-ManagedThreadFactory-engine-Thread-29551) [3ccdc46c] Failed to migrate VM 'windows_10_new_israel'" in engine.log

Expected results: The VM must just stay in Pause state , not trying to migrate


Additional info:
logs and screenshot attached

Comment 1 Tomas Jelinek 2017-11-29 15:01:00 UTC
(In reply to Polina from comment #0)
> Created attachment 1360356 [details]
> logs and screenshot
> 
> Description of problem:
> A VM with AutoResume option set in case of I/O Error must just be Paused and
> then Resumed after the storage is returned.
> 
> Version-Release number of selected component (if applicable):
> rhvm-4.2.0-0.5.master.el7.noarch
> 
> How reproducible:100%
> 
> 
> Steps to Reproduce:
> 1.create VM , windows OS , scsi storage domain. Run. 
> 2.Block all the storages on the host (scsi and nfs - the bug doesn't happen
> if only scsi is blocked)
> 3.The VM is Paused(it is ok and expected). Then unexpectedly the VM tries to
> migrate (unsuccessfully) bringing failure task and also error in engine log
> 
> Actual results: the failed event task - Migrating VM windows_10_new_israel.
> and also "ERROR [org.ovirt.engine.core.bll.SetNonOperationalVdsCommand]
> (EE-ManagedThreadFactory-engine-Thread-29551) [3ccdc46c] Failed to migrate
> VM 'windows_10_new_israel'" in engine.log

This is not related to the resume behavior. The thing is that the host become non operational (due to lost storage connectivity) and engine decided to evacuate the VMs. You can disable this in the:
edit cluster dialog -> migration policy side tab -> resilience policy section ->   Do Not Migrate Virtual Machines option.

> 
> Expected results: The VM must just stay in Pause state , not trying to
> migrate
> 
> 
> Additional info:
> logs and screenshot attached


Note You need to log in before you can comment on or make changes to this bug.