Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518721 - Confusing name of a directory where a repository is exported.
Summary: Confusing name of a directory where a repository is exported.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 14:01 UTC by Sergei Petrosian
Modified: 2019-02-07 12:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 12:03:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1466060 None None None 2017-11-29 14:01:02 UTC

Description Sergei Petrosian 2017-11-29 14:01:02 UTC
Description of problem:
While exporting a repository, it exports into a directory with a name mathcing the repository `group_id`, which makes it difficult to distinguish between exported directories and repositories they contain on import.
Version-Release number of selected component (if applicable):
Satellite 6.x

How reproducible:
100%

Steps to Reproduce:
Following steps in this documentation: 
https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/content_management_guide/using_iss#exporting_repositories

1. Run
----
hammer repository export --id 1
----
2. cd into the directory specified in `pulp_export_destination`
3. Find a directory with a name similar to f6243fee-86ff-463f-9cd0-c46f32b1e9fe

Actual results:
An exported directory with a weird name f6243fee-86ff-463f-9cd0-c46f32b1e9fe

Expected results:
An exported directory with a name, that makes it possible to distinguish what repository is exported into it. Because later on import it is necessary to know what repository you're importing to change CDN url and select check box of an imported repository. 

Additional info:
Current documentation improvements are here: https://bugzilla.redhat.com/show_bug.cgi?id=1466060

Comment 2 Brad Buckingham 2017-12-07 20:43:15 UTC
Chris,

Is the behavior described working as designed?

Is there a reason or explanation for the naming that is or needs to be used for the exported content?

Thanks!

Comment 3 Chris Duryee 2018-01-15 16:49:50 UTC
This is working as expected, but is not an ideal user experience since the UUID is exposed.

IMO its ok to leave this open, but we may want to fix this as part of a larger effort to address usability issues with disconnected exports and not as a one-off for this particular bug.

Comment 4 Bryan Kearney 2018-11-30 15:00:02 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 5 Bryan Kearney 2019-02-07 12:03:50 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.