Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518714 - Amphora failover protocol is broken
Summary: Amphora failover protocol is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 13.0 (Queens)
Assignee: Assaf Muller
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 13:57 UTC by belharar
Modified: 2018-06-26 15:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 15:57:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 523931 None None None 2017-12-11 15:09:02 UTC

Description belharar 2017-11-29 13:57:45 UTC
Description of problem:
Amphora failover protocol is broken in stable/pike and master.
When a failover protocol is triggered, the loadbalancer enters ERROR state and fail to recover.

Version-Release number of selected component (if applicable):
OSP12, and upstream master

Steps to Reproduce:
1. Create a loadbalancer, and wait for it to go active
2. Trigger loadbalancer_failover call


Actual results:
provisioning_status = ERROR

Additional info:
Suspected commit to introduce the bug: 8baf0ca1d7a9a64c2ae80b5d8731b36b0d16a901
Fix proposal: 610f1dd40b538fe42adda632f74d565acd69ca06

Comment 1 Alexander Stafeyev 2017-11-29 14:39:55 UTC
Hod did u initiate the loadbalancer failover call ? 
Could u detail this step please ? 

tnx

Comment 2 belharar 2017-11-29 15:08:29 UTC
Alex,
There is an API call in Octavia that is yet to be implemented in octavia-client.
You should refer to: https://developer.openstack.org/api-ref/load-balancer/v2/index.html#failover-a-load-balancer

Comment 3 belharar 2017-11-30 09:54:11 UTC
Alex,
Note that the failover API call is NOT included in OSP 12, only master (OSP13).

Although, the actual code to introduce the bug _is_ included in OSP12, the failure arises only when the relevant API call is performed. Since the failover API call is  omitted from OSP12, and it is highly unlikely to ever make its way (backported) to OSP12, the bug fix will not be backported to OSP12 at this time.

There is however, secondary issue with the deletion of a failing loadbalancer, that is currently in review[1], and is a good candidate for backport to OSP12.

[1] https://review.openstack.org/#/q/I051e3184208c1ad1fb53f57fe6f1c537149337b1


Note You need to log in before you can comment on or make changes to this bug.