Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518704 - Cannot upload image to glance in OSP12 + TLS everywhere + Ceph cluster
Summary: Cannot upload image to glance in OSP12 + TLS everywhere + Ceph cluster
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ga
: ---
Assignee: Cyril Roelandt
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 13:52 UTC by Artem Hrechanychenko
Modified: 2017-11-29 16:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 16:22:15 UTC


Attachments (Terms of Use)
glance-api.log (deleted)
2017-11-29 13:52 UTC, Artem Hrechanychenko
no flags Details

Description Artem Hrechanychenko 2017-11-29 13:52:17 UTC
Created attachment 1360316 [details]
glance-api.log

Description of problem:


(overcloud) [stack@undercloud-0 ~]$ glance image-create --name cirros_test_2 --disk-format qcow2 --container-format bare --file cirros-0.3.4-x86_64-disk.img 
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | bare                                 |
| created_at       | 2017-11-29T13:47:06Z                 |
| disk_format      | qcow2                                |
| id               | 7de21f6d-2960-4c9f-bda5-c586ebadb493 |
| locations        | []                                   |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | cirros_test_2                        |
| owner            | 7191f8024308462b855e9a4281bbc8d7     |
| protected        | False                                |
| size             | None                                 |
| status           | queued                               |
| tags             | []                                   |
| updated_at       | 2017-11-29T13:47:06Z                 |
| virtual_size     | None                                 |
| visibility       | shared                               |
+------------------+--------------------------------------+
504 Gateway Timeout: Gateway Timeout: The gateway did not receive a timely response: from the upstream server or application. (HTTP N/A)


after deployment OSP12+TLS everywhere + ceph 
http://tripleo.org/install/advanced_deployment/ssl.html#tls-everywhere-for-the-overcloud

I cannot upload image to glance
(overcloud) [stack@undercloud-0 ~]$ openstack image list
+--------------------------------------+---------------+--------+
| ID                                   | Name          | Status |
+--------------------------------------+---------------+--------+
| f1ba754e-cc63-4be1-8fbb-a1a1ab562702 | cirros_test_3 | saving |
| 57eb584d-8f4d-4a90-ad8d-3acad59fb60c | some-cirros2  | saving |
+--------------------------------------+---------------+--------+

so[stack@undercloud-0 ~]$ source keystonerc_master 
(overcloud) [stack@undercloud-0 ~]$ glance image-create --name cirros_test_3 --disk-format qcow2 --container-format bare --file cirros-0.3.4-x86_64-disk.img 
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | bare                                 |
| created_at       | 2017-11-29T12:51:35Z                 |
| disk_format      | qcow2                                |
| id               | 66dc36b7-b2c1-4cf3-a001-f2cc0a4d4116 |
| locations        | []                                   |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | cirros_test_3                        |
| owner            | 7191f8024308462b855e9a4281bbc8d7     |
| protected        | False                                |
| size             | None                                 |
| status           | queued                               |
| tags             | []                                   |
| updated_at       | 2017-11-29T12:51:35Z                 |
| virtual_size     | None                                 |
| visibility       | shared                               |
+------------------+--------------------------------------+
Error finding address for https://overcloud.redhat.local:13292/v2/images/66dc36b7-b2c1-4cf3-a001-f2cc0a4d4116/file: Unable to establish connection to https://overcloud.redhat.local:13292/v2/images/66dc36b7-b2c1-4cf3-a001-f2cc0a4d4116/file: [Errno 32] Broken pipe


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Artem Hrechanychenko 2017-11-29 13:59:44 UTC
Version-Release number of selected component (if applicable):
docker images from 12.0-20171122.1 
(undercloud) [stack@undercloud-0 ~]$ sudo rpm -qa "*openstack*"
puppet-openstacklib-11.3.0-2.el7ost.noarch
openstack-swift-account-2.15.1-3.el7ost.noarch
openstack-swift-proxy-2.15.1-3.el7ost.noarch
openstack-ironic-api-9.1.2-3.el7ost.noarch
openstack-tripleo-common-7.6.3-4.el7ost.noarch
openstack-mistral-common-5.2.0-1.el7ost.noarch
openstack-tripleo-validations-7.4.2-1.el7ost.noarch
openstack-nova-api-16.0.2-2.el7ost.noarch
openstack-nova-conductor-16.0.2-2.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-13.el7ost.noarch
openstack-neutron-openvswitch-11.0.1-5.el7ost.noarch
python-openstackclient-lang-3.12.0-1.el7ost.noarch
openstack-heat-engine-9.0.1-3.el7ost.noarch
openstack-mistral-executor-5.2.0-1.el7ost.noarch
openstack-nova-common-16.0.2-2.el7ost.noarch
openstack-heat-common-9.0.1-3.el7ost.noarch
openstack-keystone-12.0.0-3.el7ost.noarch
puppet-openstack_extras-11.3.0-2.el7ost.noarch
openstack-tripleo-common-containers-7.6.3-4.el7ost.noarch
openstack-mistral-engine-5.2.0-1.el7ost.noarch
openstack-zaqar-5.0.0-3.el7ost.noarch
openstack-swift-container-2.15.1-3.el7ost.noarch
openstack-heat-api-9.0.1-3.el7ost.noarch
openstack-ironic-common-9.1.2-3.el7ost.noarch
openstack-mistral-api-5.2.0-1.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.1-1.el7ost.noarch
openstack-nova-scheduler-16.0.2-2.el7ost.noarch
openstack-glance-15.0.0-3.el7ost.noarch
openstack-puppet-modules-11.0.0-1.el7ost.noarch
openstack-neutron-ml2-11.0.1-5.el7ost.noarch
openstack-heat-api-cfn-9.0.1-3.el7ost.noarch
openstack-tripleo-ui-7.4.3-4.el7ost.noarch
openstack-nova-compute-16.0.2-2.el7ost.noarch
openstack-neutron-11.0.1-5.el7ost.noarch
openstack-ironic-conductor-9.1.2-3.el7ost.noarch
python-openstackclient-3.12.0-1.el7ost.noarch
openstack-tempest-17.1.0-1.el7ost.noarch
openstack-selinux-0.8.11-1.el7ost.noarch
openstack-nova-placement-api-16.0.2-2.el7ost.noarch
openstack-swift-object-2.15.1-3.el7ost.noarch
openstack-neutron-common-11.0.1-5.el7ost.noarch
python-openstacksdk-0.9.17-1.el7ost.noarch
openstack-ironic-inspector-6.0.0-3.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-1.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. apply w/a for https://bugzilla.redhat.com/show_bug.cgi?id=1517903
2. deploy OSP12 + TLS everywhere+ Ceph
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/OT2_container_netiso_osp12_HA_TLS_everywhere/configure
3. try to upload image to oc glance

Actual results:
504

Expected results:
success

Additional info:

Comment 3 Giulio Fidente 2017-11-29 14:15:32 UTC
Ceph was not writable because no OSDs were brought up. OSDs activation failed because the disks were not clean, there were pre-existing partitions from a previous deployment.

It is also worth pointing out that we have an open issue for ceph-ansible BZ #1499136 which is exiting with 0 (as if everything succeeded) when 0 OSDs are up.

Comment 4 Artem Hrechanychenko 2017-11-29 16:22:15 UTC
(In reply to Giulio Fidente from comment #3)
> Ceph was not writable because no OSDs were brought up. OSDs activation
> failed because the disks were not clean, there were pre-existing partitions
> from a previous deployment.
> 
> It is also worth pointing out that we have an open issue for ceph-ansible BZ
> #1499136 which is exiting with 0 (as if everything succeeded) when 0 OSDs
> are up.

Yep,
after removing empty osd and re-deploy image was upload to glance and instance which use cirros as boot image was launch

Close as not a bug


Note You need to log in before you can comment on or make changes to this bug.