Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518702 - Webadmin - ImageIO- UI - canceling failed upload is not possible via 'upload' button but only via 'download' button
Summary: Webadmin - ImageIO- UI - canceling failed upload is not possible via 'upload...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Idan Shaby
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 13:46 UTC by Avihai
Modified: 2017-12-20 10:49 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.2.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:49:45 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85176 master MERGED frontend: upload/download disk's buttons availability 2017-12-10 11:31:52 UTC

Description Avihai 2017-11-29 13:46:34 UTC
Description of problem:
Canceling a failed disk upload is not possible as this option is greyed out via 'upload' button options.
Only via 'download' button, we can cancel a failed upload.

Version-Release number of selected component (if applicable):
4.2.0-0.5.master.el7

How reproducible:
100%


Steps to Reproduce:
1.Start an upload via SDK script & fail is so in UI you see that upload is still in process. 
2.Go to upload button & try to cancel the upload.

Actual results:
You can't as the 'cancle' button is greyed out.

Expected results:

Additional info:

Workaround:
Use 'download' cancel option to cancel the upload.

Comment 1 Sandro Bonazzola 2017-12-12 16:03:56 UTC
This bug is targeted 4.2.1 but is modified in 4.2.0.
Can you please check / verify this bug status and set target milestone and bug status accordingly?

Comment 2 Allon Mureinik 2017-12-12 17:19:16 UTC
The fix is included in the ovirt-engine-4.2.0.1 tag.

Comment 3 Avihai 2017-12-13 08:56:44 UTC
Verified . 
Engine : 4.2.0-0.6.el7

Comment 4 Sandro Bonazzola 2017-12-20 10:49:45 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.