Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518546 - 'Tendrl server' to be replaced with 'Web Admin server' in Hosts tab, field 'Role'.
Summary: 'Tendrl server' to be replaced with 'Web Admin server' in Hosts tab, field 'R...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Neha Gupta
QA Contact: Sweta Anandpara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 07:48 UTC by Sweta Anandpara
Modified: 2017-12-18 04:38 UTC (History)
5 users (show)

Fixed In Version: tendrl-ui-1.5.4-6.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:38:26 UTC


Attachments (Terms of Use)
Screenshot of UI (deleted)
2017-11-29 07:48 UTC, Sweta Anandpara
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Sweta Anandpara 2017-11-29 07:48:52 UTC
Created attachment 1360204 [details]
Screenshot of UI

Description of problem:
=========================
On a freshly installed setup, the 'Hosts' tab shows 'Role' correctly as 'Gluster peer' for all the storage nodes, but it shows 'Tendrl server' for the Web-admin server.

There is a similar bug for Grafana dashboard, where every reference of 'Tendrl' has to be changed to 'Web Admin', or a variant thereof.. BZ https://bugzilla.redhat.com/show_bug.cgi?id=1515104. Giving this reference as the same naming convention needs to be followed in both the pages.

Version-Release number of selected component (if applicable):
===========================================================
tendrl-ui-1.5.4-4.el7rhgs.noarch

How reproducible:
================
Always


Additional info:
================
Screenshot attached.

Comment 3 Sweta Anandpara 2017-12-08 08:27:41 UTC
Tested and verified this on the build details mentioned below. 
Hosts tab shows 'Tendrl' being replaced with 'Web Admin'. Moving this to verified in RHGS 3.3.1.

tendrl-monitoring-integration-1.5.4-13.el7rhgs.noarch
tendrl-commons-1.5.4-8.el7rhgs.noarch
tendrl-api-httpd-1.5.4-4.el7rhgs.noarch
tendrl-ansible-1.5.4-5.el7rhgs.noarch
tendrl-selinux-1.5.4-1.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-13.el7rhgs.noarch
tendrl-notifier-1.5.4-6.el7rhgs.noarch
tendrl-node-agent-1.5.4-14.el7rhgs.noarch
tendrl-ui-1.5.4-6.el7rhgs.noarch
tendrl-grafana-selinux-1.5.4-1.el7rhgs.noarch
tendrl-api-1.5.4-4.el7rhgs.noarch

Comment 5 errata-xmlrpc 2017-12-18 04:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.