Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518526 - Guest crashed during rebooting [NEEDINFO]
Summary: Guest crashed during rebooting
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.5-Alt
Hardware: ppc64le
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Ming Lei
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 06:57 UTC by Xujun Ma
Modified: 2017-11-29 12:47 UTC (History)
8 users (show)

Fixed In Version: kernel-alt-4.14.0-8.el7a
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 12:44:09 UTC
qzhang: needinfo? (xuma)
minlei: needinfo? (xuma)


Attachments (Terms of Use)

Description Xujun Ma 2017-11-29 06:57:43 UTC
Description of problem:
Guest crashed during rebooting

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.10.0-9.el7.ppc64le
host&guest:kernel-4.14.0-7.el7a.ppc64le

How reproducible:
100%

Steps to Reproduce:
1.Boot up guest with command
/usr/libexec/qemu-kvm \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=0x7 \
    -drive id=drive_image1,if=none,aio=native,cache=none,format=qcow2,file=ALT-Server-7.5-ppc64le-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -m 8192,slots=2,maxmem=16G \
    -nodefaults \
    -device virtio-net-pci,mac=9a:79:7a:7b:7c:7d,id=idnW3nZi,vectors=4,netdev=idXOO0Sj,bus=pci.0,addr=0x8  \
    -netdev tap,id=idXOO0Sj,vhost=on \
    -smp 4,maxcpus=8,sockets=1,cores=1,threads=4 \
    -mon chardev=serial_id_serial0,mode=readline \
    -vga std \
    -vnc :4 \
    -chardev stdio,mux=on,id=serial_id_serial0,server,nowait,signal=off \
    -device spapr-vty,id=serial111,chardev=serial_id_serial0 \
    -qmp-pretty tcp:0:4444,server,nowait \
    -rtc base=utc,clock=host \

2.Reboot in guest
#reboot
3.

Actual results:
Guest crashed during rebooting with call trace:
[   54.341556] Ebtables v2.0 unregistered
[   55.087438] XFS (sda2): Unmounting Filesystem
[   55.290424] systemd-shutdown[1]: Sending SIGTERM to remaining processes...
[   55.301408] systemd-journald[624]: Received SIGTERM from PID 1 (systemd-shutdow).
[   55.388112] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
[   55.396778] systemd-shutdown[1]: Unmounting file systems.
[   55.399707] systemd-shutdown[1]: Remounting '/' read-only with options 'seclabel,attr2,inode64,noquota'.
[   55.631871] systemd-shutdown[1]: Remounting '/' read-only with options 'seclabel,attr2,inode64,noquota'.
[   55.638874] systemd-shutdown[1]: All filesystems unmounted.
[   55.641499] systemd-shutdown[1]: Deactivating swaps.
[   55.644054] systemd-shutdown[1]: All swaps deactivated.
[   55.646581] systemd-shutdown[1]: Detaching loop devices.
[   55.658890] systemd-shutdown[1]: All loop devices detached.
[   55.661873] Unable to handle kernel paging request for instruction fetch
[   55.664642] Faulting instruction address: 0x00000000
[   55.667135] Oops: Kernel access of bad area, sig: 11 [#1]
[   55.669694] LE SMP NR_CPUS=2048 NUMA pSeries
[   55.672079] Modules linked in: fuse ip_set nfnetlink bridge stp llc sg xfs libcrc32c sd_mod bochs_drm virtio_net drm_kms_helper virtio_scsi scsi_transport_iscsi syscopyarea sysfillrect sysimgblt fb_sys_fops ttm drm virtio_pci i2c_core virtio_ring virtio dm_mirror dm_region_hash dm_log dm_mod [last unloaded: ip_tables]
[   55.681985] CPU: 1 PID: 1 Comm: systemd-shutdow Not tainted 4.14.0-7.el7a.ppc64le #1
[   55.685089] task: c0000001fdfe0000 task.stack: c0000001fa080000
[   55.688006] NIP:  0000000000000000 LR: c0000000006203ac CTR: 0000000000000000
[   55.691082] REGS: c0000001fa083700 TRAP: 0400   Not tainted  (4.14.0-7.el7a.ppc64le)
[   55.694242] MSR:  8000000040009033 <SF,EE,ME,IR,DR,RI,LE>  CR: 28042442  XER: 00000000
[   55.697475] CFAR: c0000000006203a8 SOFTE: 0 
[   55.697475] GPR00: c00000000062035c c0000001fa083980 c0000000014ca600 c000000006704b60 
[   55.697475] GPR04: 0000000000000001 0000000000000000 0000000000000001 0000000000000003 
[   55.697475] GPR08: 0000000000000000 0000000000000000 0000000000000001 c00800000169a7d8 
[   55.697475] GPR12: 0000000000000000 c000000007ac0a80 000000013d370480 0000000000000000 
[   55.697475] GPR16: 000000013d36ff50 000000013d36ff00 000000013d36fd80 000000013d36fe30 
[   55.697475] GPR20: 0000000000000001 00007fffd9cee810 0000000000000000 0000000000000000 
[   55.697475] GPR24: 0000000000000003 c0000001e5f50500 0000000000000004 0000000000000000 
[   55.697475] GPR28: 0000000000000000 c000000006704b60 0000000000000001 c000000006704b60 
[   55.725692] NIP [0000000000000000]           (null)
[   55.728327] LR [c0000000006203ac] blk_run_queue+0x8c/0xf0
[   55.731018] Call Trace:
[   55.733216] [c0000001fa083980] [c00000000062035c] blk_run_queue+0x3c/0xf0 (unreliable)
[   55.736345] [c0000001fa0839b0] [c0000000006374a4] blk_freeze_queue_start+0xa4/0xb0
[   55.739406] [c0000001fa0839e0] [c00000000061d190] blk_set_queue_dying+0x70/0x1b0
[   55.742439] [c0000001fa083a10] [c0080000016854e8] dm_destroy+0xa8/0x210 [dm_mod]
[   55.745459] [c0000001fa083a60] [c00800000168fa44] dev_remove+0x1a4/0x250 [dm_mod]
[   55.748483] [c0000001fa083af0] [c00800000168de30] ctl_ioctl+0x370/0x540 [dm_mod]
[   55.751506] [c0000001fa083ce0] [c00800000168e038] dm_ctl_ioctl+0x38/0x50 [dm_mod]
[   55.754524] [c0000001fa083d20] [c0000000004632e0] do_vfs_ioctl+0xe0/0xa80
[   55.757375] [c0000001fa083de0] [c000000000463d54] SyS_ioctl+0xd4/0x130
[   55.760194] [c0000001fa083e30] [c00000000000b184] system_call+0x58/0x6c
[   55.763020] Instruction dump:
[   55.765289] XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX 
[   55.768337] XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX 
[   55.771373] ---[ end trace d70b295fec5ceb16 ]---
[   55.777807] 
[   55.779791] Sending IPI to other CPUs
[   55.782904] IPI complete
[   55.787060] kexec: Starting switchover sequence.



Expected results:
Guest reboot smoothly.

Additional info:

Comment 2 Qunfang Zhang 2017-11-29 08:33:25 UTC
Xujun,

Is this a regression from latest kernel-alt? Do you hit this bug in our RHEL7.5 Power 8 acceptance test?

Thanks!

Comment 6 Herton R. Krzesinski 2017-11-29 12:44:09 UTC
I already reverted all patches from bug 1513036 in kernel-alt-4.14.0-8.el7a. Please work on bug 1513036 and resend updated/fixed patches once they are ready and tested.

*** This bug has been marked as a duplicate of bug 1513036 ***


Note You need to log in before you can comment on or make changes to this bug.