Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518504 - [RFE] Asymmetric brick configuration
Summary: [RFE] Asymmetric brick configuration
Keywords:
Status: CLOSED DUPLICATE of bug 1518345
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.1
: ---
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1518344
TreeView+ depends on / blocked
 
Reported: 2017-11-29 06:01 UTC by Sahina Bose
Modified: 2018-06-13 05:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1518344
Environment:
Last Closed: 2017-12-04 07:05:31 UTC
oVirt Team: Gluster
sabose: ovirt-4.2?
sabose: planning_ack?
sabose: devel_ack?
sabose: testing_ack?


Attachments (Terms of Use)

Description Sahina Bose 2017-11-29 06:01:20 UTC
+++ This bug was initially created as a clone of Bug #1518344 +++

Description of problem:
-----------------------
Cockpit provides option to configure bricks exactly the same way on all the nodes. Example is that the brick could be created from sdb on all the nodes.

If the user wanted to make use of sdb from node1, sdc from node2, and sdd from node3. Then this is not possible with the existing cockpit.

Specifically this requirement becomes essential when arbitrated replicate volume is chosen. Arbitrated replicate volume requires the arbiter brick could be placed on the disk which has less storage space.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.9

How reproducible:
-----------------
Not Applicable

Steps to Reproduce:
-------------------
1. Start with the installation of RHHI deployment
2. Choose arbitrated replicate volume for 'data' and 'vmstore' volume

Actual results:
----------------
Cockpit limits the user to create bricks symmetrically on the all nodes. 
If 'sdb' is chosen, bricks are created on 'sdb' on all the nodes

Expected results:
-----------------
Asymmetric brick configuration should be allowed for users to create bricks on specific disks

Additional info:
-----------------
With this limitation in place, the users can solve this problem by editing the generated gdeploy configuration. But again this is error prone and hard to edit the generated gdeploy configuration file.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-11-28 11:41:56 EST ---

This bug is automatically being proposed for the current release of Red Hat Hyperconverged Infrastructure (RHHI) under active development, by setting the release flag 'rhhi‑1.1.0' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

Comment 1 Sahina Bose 2017-12-04 07:05:31 UTC

*** This bug has been marked as a duplicate of bug 1518345 ***


Note You need to log in before you can comment on or make changes to this bug.