Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518476 - "Unable to get list of updates" when trying to check updates in Fedora 26 [NEEDINFO]
Summary: "Unable to get list of updates" when trying to check updates in Fedora 26
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 26
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 03:15 UTC by Adam Williamson
Modified: 2018-05-29 12:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:17:24 UTC
awilliam: needinfo? (rhughes)


Attachments (Terms of Use)
journal output from a boot where I reproduced the bug (deleted)
2017-11-29 20:44 UTC, Adam Williamson
no flags Details
gnome-shell --verbose output from a run which hit the bug (deleted)
2017-11-29 20:46 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2017-11-29 03:15:45 UTC
For the last two weeks, the openQA test which checks whether updating with GNOME Software works has failed every time it's run on Fedora 26. It works fine with Fedora 25 and Fedora 27.

When the test goes to the 'Updates' tab of gnome-software and hits the 'Refresh' button, an error message "Unable to get list of updates" is displayed.

I've reproduced this manually by doing the following:

1. Install Fedora 26 Workstation live
2. Create a side repository with packages from some update in it:
   mkdir -p /opt/update_repo
   cd /opt/update_repo
   dnf -y install bodhi-client git createrepo koji
   bodhi updates download --updateid FEDORA-2017-93988a5e1a
   createrepo .
   printf "[advisory]\nname=Advisory repo\nbaseurl=file:///opt/update_repo\nenabled=1\nmetadata_expire=3600\ngpgcheck=0" > /etc/yum.repos.d/advisory.repo
3. Update the system with dnf: 'dnf -y update'
4. Reboot
5. Run gnome-software, go to Updates tab, click refresh

I don't know yet if the stuff about the side repository is actually key to the reproduction or not. Once it's been created and the bug has been triggered, if I remove that repository config file and reboot, the bug persists, but I haven't yet tested if I can reproduce the bug simply by installing Workstation, updating the system, rebooting and running Software, without ever creating the side repo.

There doesn't appear to be anything terribly useful in the system journal about the problem. I can run gnome-software --verbose and it dumps a whole bunch of info on the console, but not sure if any of it is useful. However, I'll attach both.

Comment 1 Adam Williamson 2017-11-29 03:19:55 UTC
Hmm, the reproducer seems a bit temperamental - I went to attach the logs and it's not reproducing any more. Will try to attach logs in the morning.

Comment 2 Adam Williamson 2017-11-29 20:43:24 UTC
The side repo does seem necessary to this: I tried again with the reproducer, this time skipping the sideo repo step, and the bug didn't happen. Only when I added the side repo and rebooted did the bug show up. I have logs from this attempt, which I will attach.

Comment 3 Adam Williamson 2017-11-29 20:44:18 UTC
Created attachment 1360538 [details]
journal output from a boot where I reproduced the bug

Comment 4 Adam Williamson 2017-11-29 20:46:09 UTC
Created attachment 1360539 [details]
gnome-shell --verbose output from a run which hit the bug

Comment 5 Richard Hughes 2017-12-14 15:38:42 UTC
From the journal logs:

> failed to call gs_plugin_refresh on packagekit-refresh: cancelled by user action

I'm guessing that's not correct.

Comment 6 Adam Williamson 2017-12-14 17:07:37 UTC
Hum - didn't we have another case where a 'cancelled by user action' error was happening because dnf was refreshing its cache in the background so dnf and Software were fighting for db access? I believe I have a workaround for that in openQA...could this just be the same case but the resulting behaviour has changed a bit for some reason?

https://bugzilla.redhat.com/show_bug.cgi?id=1314991

Comment 7 Adam Williamson 2017-12-19 21:29:05 UTC
Yeah, so, I'm starting to think this is just the same as #1314991 , except Software has changed how it behaves when it hits that problem. Now instead of the GNOME Software UI changing to an almost blank grey with a 'prohibited' crossed-circle icon and 'cancelled by user action' under it - that is, https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/needles/gnome/desktop_package_tool_update_bz1314991.png - we get this sort of 'notification' saying "Unable to get list of updates" - that is, https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/needles/gnome/desktop_package_tool_update_bz1314991-20171219.png .

Richard, can you confirm that something changed in Software's error handling that would be consistent with this change in what the user sees in response to the same underlying problem? If so, I'll close this as a dupe of #1314991.

Comment 8 Fedora End Of Life 2018-05-03 07:56:31 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 9 Fedora End Of Life 2018-05-29 12:17:24 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.