Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518448 - [abrt] solaar: update(): window.py:795:update:AssertionError
Summary: [abrt] solaar: update(): window.py:795:update:AssertionError
Keywords:
Status: CLOSED DUPLICATE of bug 1487640
Alias: None
Product: Fedora
Classification: Fedora
Component: solaar
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:299c4a310e05b25171d8208def4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 23:04 UTC by Jan Vlug
Modified: 2018-07-27 21:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 21:18:37 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: cgroup (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: cpuinfo (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: environ (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: mountinfo (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: namespaces (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details
File: open_fds (deleted)
2017-11-28 23:04 UTC, Jan Vlug
no flags Details

Description Jan Vlug 2017-11-28 23:04:09 UTC
Version-Release number of selected component:
solaar-0.9.2-4.20150528gitcf27328.fc27.6

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python /bin/solaar
crash_function: update
exception_type: AssertionError
executable:     /bin/solaar
kernel:         4.13.12-300.fc27.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
window.py:795:update:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/solaar/ui/__init__.py", line 165, in _status_changed
    window.update(device, need_popup)
  File "/usr/lib/python2.7/site-packages/solaar/ui/window.py", line 795, in update
    assert device.receiver
AssertionError

Local variables in innermost frame:
device: <PairedDevice(1,1013,V550 Nano)>
is_paired: False
selected_device_id: None
need_popup: 0

Potential duplicate: bug 1282148

Comment 1 Jan Vlug 2017-11-28 23:04:15 UTC
Created attachment 1360098 [details]
File: backtrace

Comment 2 Jan Vlug 2017-11-28 23:04:16 UTC
Created attachment 1360099 [details]
File: cgroup

Comment 3 Jan Vlug 2017-11-28 23:04:18 UTC
Created attachment 1360100 [details]
File: cpuinfo

Comment 4 Jan Vlug 2017-11-28 23:04:19 UTC
Created attachment 1360101 [details]
File: environ

Comment 5 Jan Vlug 2017-11-28 23:04:21 UTC
Created attachment 1360102 [details]
File: mountinfo

Comment 6 Jan Vlug 2017-11-28 23:04:23 UTC
Created attachment 1360103 [details]
File: namespaces

Comment 7 Jan Vlug 2017-11-28 23:04:24 UTC
Created attachment 1360104 [details]
File: open_fds

Comment 8 Jason Tibbitts 2018-07-27 21:18:37 UTC

*** This bug has been marked as a duplicate of bug 1487640 ***


Note You need to log in before you can comment on or make changes to this bug.