Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518436 - "Unexpected Error Encountered" for live migrate on OSP instance
Summary: "Unexpected Error Encountered" for live migrate on OSP instance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Sam Lucidi
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1524676
TreeView+ depends on / blocked
 
Reported: 2017-11-28 22:23 UTC by Brant Evans
Modified: 2018-06-21 21:19 UTC (History)
12 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1524676 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:19:19 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)

Description Brant Evans 2017-11-28 22:23:29 UTC
Description of problem:
Attempting to Live Migrate OSP instances when navigating through the provider results in an error page being displayed.

 and . Click on Instances and then check one or more instances. Finally . An error page is displayed instead of the actual page. Error is  Functionality works when accessed from Compute > Cloud > Instances.

Version-Release number of selected component (if applicable):
5.9.0.11

How reproducible:
Always

Steps to Reproduce:
1. Configure CloudForms with an OSP Cloud provider
2. Navigate to Compute > Cloud > Providers
3. Select the OSP provider
4. Click on Instances
5. Check one or more instances
6. Select Lifecycle -> Migrate Selected Instances

Actual results:
Error page is shown with the error of "undefined method `id' for nil:NilClass [vm/live_migrate]"


Expected results:
"Migrate Selected Instances" page should be displayed.

Additional info:
When performing the "Migrate Selected Instances" from the Compute > Clouds > Instances page the "Migrate Selected Instances" page is correctly shown.

Comment 2 Dave Johnson 2017-11-28 22:43:35 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Dave Johnson 2017-11-28 23:02:33 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 4 Ladislav Smola 2017-11-29 11:20:07 UTC
This might be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1514334 , which broke all list actions.

Comment 8 Martin Povolny 2017-11-30 09:33:09 UTC
I don't think it was ever designed to work in this context by the original implementor.

looking at app/views/vm_common/_live_migrate.html.haml

there's this condition: `unless @explorer`

meaning the original implementor mistakely assumed that a single item case equals called from the explorer screen.

The broken case is a multiple items case on a non-explorer screens. The condition should have never been written this way :-(

This is not a regression, this could have never worked and also this has no relation to GTLs.

My guess is that just a simple test:

`if @record.present?` in place of the `unless @explorer` should fix the problem.


Quick fix is here:
https://github.com/ManageIQ/manageiq-ui-classic/pull/2877

Please, take is from there, add tests etc.


btw:
Ladas, Marek, guys, I suggest spending 5-10 minutes on a BZ before bouncing it here and there. Thank you!


Note You need to log in before you can comment on or make changes to this bug.