Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518428 - Export storage domain is not recovered in a DR scenario
Summary: Export storage domain is not recovered in a DR scenario
Keywords:
Status: CLOSED DUPLICATE of bug 1533428
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ovirt-4.2.2
: ---
Assignee: Maor
QA Contact: meital avital
URL:
Whiteboard: DR
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 21:54 UTC by Maor
Modified: 2018-01-11 14:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-11 14:18:04 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)

Description Maor 2017-11-28 21:54:40 UTC
Description of problem:
On a DR site to site scenario we fail over and fail back the engine setup syncing between the storage domains replications.
Since export storage domain can not be force detach, it can not be re-attach  to the setup without adjusting its meta data (see https://www.ovirt.org/documentation/how-to/storage/clear-the-storage-domain-pool-config-of-an-exported-nfs-domain/)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Add an export storage domain to the setup
2. Make the export domain replicated to another storage domain (or use the existing one)
3. Try to fail over the setup and attach the export storage domain from oVirt 


Actual results:
Attaching the export domain will fail since the metadata consists the pool uuid

Expected results:
We should add an ansible script to clean the export storage domain metadata

Additional info:

Comment 2 Yaniv Kaul 2017-11-29 13:14:55 UTC
Severity?

Comment 3 Maor 2017-11-29 15:39:54 UTC
Export domain does not run any VMs, so I don't see any crucial impact if the user will manually have to attach it again, combined with the fact that we plan to make export domain obsolete and use it as a data domain, I would make it a low severity

Feel free to change if you think otherwise

Comment 4 Maor 2018-01-11 14:18:04 UTC
Noticed now that I opened a duplicate bug on that issue, closing this one since BZ1533428 already applied with the correct product/component.

*** This bug has been marked as a duplicate of bug 1533428 ***


Note You need to log in before you can comment on or make changes to this bug.