Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518396 - Yum repository mirrors are structurally broken from a recent change
Summary: Yum repository mirrors are structurally broken from a recent change
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 26
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Patrick Uiterwijk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 20:11 UTC by Ted
Modified: 2017-11-28 21:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 21:52:35 UTC


Attachments (Terms of Use)

Description Ted 2017-11-28 20:11:55 UTC
Description of problem:
Someone appears to have made a change to the script on your end that generates the yum repository "updates" directories on Fedora mirrors.  The structure of the repositories appears to have been changed for Fedora 27 by adding a Packages directory and the change has inadvertently broken the repos for Fedora 25 and 26.

I couldn't figure out why my repos suddenly doubled in size and this turned out to be the issue.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Go to any mirror repository (for example: http://mirror.math.princeton.edu/pub/fedora/linux/updates/26/x86_64/
2.  You will see directories with letters / numbers, but now there is an additional directory called Packages
3.  The lettered / numbered directories are no longer being updated
4.  All of the updates are going into the Packages directory that previously didn't exist.
5.  Although dnf probably will still work correctly for the majority of users, it has made my local mirrors double in size.

Actual results:
Mirrors are much larger than normal, and some users that sync local mirrors may not be getting OS updates at all depending on how they are syncing the repositories.

Expected results:
Please fix the paths to sync to the old location or remove the outdated files that are not longer receiving patches


Additional info:
I have already updated my local repositories to work around the problem.  I just thought that somebody should maybe be notified that it is broken.

Comment 1 Ted 2017-11-28 20:18:53 UTC
Looks like the updates tree for SRPMS and debug packages have the same problem.

Comment 2 Patrick Uiterwijk 2017-11-28 21:52:35 UTC
This is a result of a change in our repo generation tooling. The extra directories had been hardlinked to make sure that mirrors didn't have to redownload everything if they mirrored with hardlinking on.
The extra directories (outside of Packages/) have now been removed from the master mirrors, so that it's back to one copy of everything.
Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.