Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151837 - Next, Help, Release Notes are gone until you hover mouse, they appear.
Summary: Next, Help, Release Notes are gone until you hover mouse, they appear.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
: 152346 154611 155101 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-22 19:27 UTC by Jason C. Rochon
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 17:29:42 UTC


Attachments (Terms of Use)
recreation of complete window (deleted)
2005-04-26 21:27 UTC, Ronny Buchmann
no flags Details | Diff

Description Jason C. Rochon 2005-03-22 19:27:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
Next, Help, Release Notes buttons are gone until you hover mouse over where they should be, then they appear.


Dell SX260
256MB
P4 1.6ghz
KVM splitter

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Regular install not the text-based
2. Begin install of the system
3. Hover mouse where bottom buttons should be (Help, Next, Release Notes)
4. Buttons appear.
5. On the next screen you will have to do the same thing to make them appear each time.  

Actual Results:  The buttons at the bottom show up each time you hover your mouse over them at each screen.

Expected Results:  The buttons should already have appeared or you wouldn't know where to go on the screen.

Additional info:

Comment 1 Chris Lumens 2005-03-28 20:17:13 UTC
*** Bug 152346 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2005-03-30 18:56:51 UTC
Are you selecting a different language?  What happens if you don't run it
through the KVM?  Can you test with rawhide and see if it's still happening?

Comment 3 Jason C. Rochon 2005-03-30 20:33:21 UTC
Still not showing up, even without KVM.

Bug# 152346 has same issue, so its probably software.

I don't know why anyone else seen this, unless they installed in text-mode.

Comment 4 Aaron Kurtz 2005-04-12 17:09:31 UTC
I saw this on FC4t1, and I saw it again on FC4t2.
P4, Nvidia GeforceFX 5600XT.

Comment 5 Jason C. Rochon 2005-04-12 19:07:13 UTC
As Aaron Kurtz states, "I saw this on FC4t1, and I saw it again on FC4t2.
P4, Nvidia GeforceFX 5600XT."

and,

Bryan Headley from #152346, "Seen on via nehemiah and IBM Pentium 2 laptop."


I am wondering if this cannot be reproduced on an AMD machine whether its a
laptop or PC.

Comment 6 Chris Lumens 2005-04-13 14:09:01 UTC
*** Bug 154611 has been marked as a duplicate of this bug. ***

Comment 7 Chris Lumens 2005-04-16 19:50:06 UTC
*** Bug 155101 has been marked as a duplicate of this bug. ***

Comment 8 Karen Pease 2005-04-18 18:39:02 UTC
FYI - I'm getting this same bug - fc4t2.

Comment 9 Chris Lumens 2005-04-21 19:32:33 UTC
Looks like this happens with a CD install or by passing "nopass" as a boot
parameter.  I see the buttons disappearing on the Keyboard Configuration screen
but after I have hovered the mouse over them, they stay on all subsequent screens.

Could everyone please confirm they're doing CD installs (or using the nopass
option if doing NFS, HTTP, whatever) and also state between which two screens
the buttons disappear?  Also, if they disappear between every screen, that'd be
handy for me to know.  Thanks.

Comment 10 Jason C. Rochon 2005-04-21 21:22:57 UTC
CD install.

Comment 11 Jason C. Rochon 2005-04-21 21:23:53 UTC
CD install.

Comment 12 Jason C. Rochon 2005-04-21 21:24:44 UTC
Wow a bug in the Bugzilla...

Comment 13 Need Real Name 2005-04-21 21:41:06 UTC
I was doing a CD install.
The situation I documented was between the "choose language" and "choose
keyboard" screens.
More info at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154611

Comment 14 Ronny Buchmann 2005-04-24 13:50:28 UTC
The behaviour described in bug #154611 is still there (10.2.0.52).
Switching to text console and back to X also draws the buttons

I'm doing CD install.


Comment 15 Chris Lumens 2005-04-25 18:55:40 UTC
I can't explain it, but I believe my recent patch for bug 149688 fixes this
problem.  We'll get another anaconda build out in time for test3 to check this.

Comment 16 Ronny Buchmann 2005-04-26 18:18:59 UTC
With this patch the buttons appear immediately, but are always in English.

Re-adding self.ics.getICW().setLanguage() produces translated buttons, but not
immediately drawn (as before).

Comment 17 Ronny Buchmann 2005-04-26 21:23:13 UTC
What about doing

self.window.destroy()
self.window = self.mainxml.get_widget("mainWindow")
self.createWidgets()
self.connectSignals()
self.setScreen()
self.window.show()

in ICW.setLanguage() ?

This produces a little flicker but actually works.


Comment 18 Ronny Buchmann 2005-04-26 21:27:07 UTC
Created attachment 113692 [details]
recreation of complete window

Comment 19 Ronny Buchmann 2005-04-26 21:29:46 UTC
this is a patch with the described changes

Comment 20 Chris Lumens 2005-04-26 22:29:24 UTC
Thanks for the patch.  Hopefully I can figure out a more permanent fix that
doesn't involve flickering (see comments in the function), but this may have to
do for test3.


Note You need to log in before you can comment on or make changes to this bug.