Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518346 - Retrace job fails for XWayland crashes
Summary: Retrace job fails for XWayland crashes
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: retrace-server
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matej Marušák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:43 UTC by Erwan Legrand
Modified: 2017-11-30 10:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 10:52:48 UTC


Attachments (Terms of Use)

Description Erwan Legrand 2017-11-28 16:43:29 UTC
Description of problem:
XWayland crashes now and then since I have upgraded to F27. Unfortunately, attempting to report the bug through retrace-server fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to report XWayland crash
2.
3.

Actual results:
--- Running analyze_CCpp ---
Ok to upload core dump? (It may contain sensitive data). If your answer is 'No', a stack trace will be generated locally. (It may download a huge amount of data). 'YES'
Querying server settings
Preparing an archive to upload
Uploading 2.3 MiB
Upload successful
Retrace job started
Preparing environment for backtrace generation
.......
Retrace job failed
Retrace failed. Try again later and if the problem persists report this issue please.
2017-11-28 16:25:47 Analyzing crash data
 2017-11-28 16:25:52 WARNING:fedora.client.openidbaseclient:Unable to create /usr/share/retrace-server/.fedora: [Errno 13] Permission denied: '/usr/share/retrace-server/.fedora'
ERROR:faf:Unable to import plugin pyfaf.actions.create_problems_gnome_mmarusak: cannot import name get_unassigned_reports_w_name
INFO:faf.Coredump2Packages:Executing eu-unstrip
INFO:faf.Coredump2Packages:Mapping build-ids into debuginfo packages
WARNING:faf.Coredump2Packages:No debuginfo found for 'e235d257e81cffa1756636ed4c98b04fdc62ed18' (/usr/lib64/freetype-freeworld/libfreetype.so.6.14.0)
INFO:faf.Coredump2Packages:Getting binary packages from debuginfos

    2017-11-28 16:25:52 Preparing environment for backtrace generation
   2017-11-28 16:27:24 /usr/bin/mock --configdir /srv/retrace/tasks/529444719 shell -- chgrp -R mockbuild /var/spool/abrt/crash exitted with 1
=== OUTPUT ===
INFO: mock.py version 1.4.7 starting (python version = 2.7.5)...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Start: chroot init
INFO: calling preinit hooks
INFO: enabled HW Info plugin
Finish: chroot init
Start: shell
chgrp: invalid group: 'mockbuild'
Finish: shell

   2017-11-28 16:27:29 None

Expected results:
Retrace job succeeds.

Additional info:

Comment 1 Miroslav Suchý 2017-11-29 07:39:54 UTC
> Start: shell
> chgrp: invalid group: 'mockbuild'

This is the reason. There is change in mock and we must change FAF to accomodate the change. Matej is already working on this.

Comment 2 Matej Marušák 2017-11-30 10:52:48 UTC
Fixed in https://github.com/abrt/retrace-server/commit/7a21085


Note You need to log in before you can comment on or make changes to this bug.