Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518344 - [RFE] Asymmetric brick configuration
Summary: [RFE] Asymmetric brick configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhi-1.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: Mugdha Soni
URL:
Whiteboard:
Depends On: 1518345 1518504
Blocks: 1520833 1548985
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:41 UTC by SATHEESARAN
Modified: 2018-11-15 11:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previous versions of RHHI for Virtualization expected each virtualization host to be set up the same way, with the same device types and device names on each. As of version 2.0, you can specify different device and sizes as appropriate for each host, size arbiter bricks appropriately, and specify an SSD to use as a LVM cache logical volume.
Clone Of:
: 1518345 1518504 1590636 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:37:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 None None None 2018-11-08 05:38:25 UTC

Description SATHEESARAN 2017-11-28 16:41:51 UTC
Description of problem:
-----------------------
Cockpit provides option to configure bricks exactly the same way on all the nodes. Example is that the brick could be created from sdb on all the nodes.

If the user wanted to make use of sdb from node1, sdc from node2, and sdd from node3. Then this is not possible with the existing cockpit.

Specifically this requirement becomes essential when arbitrated replicate volume is chosen. Arbitrated replicate volume requires the arbiter brick could be placed on the disk which has less storage space.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.9

How reproducible:
-----------------
Not Applicable

Steps to Reproduce:
-------------------
1. Start with the installation of RHHI deployment
2. Choose arbitrated replicate volume for 'data' and 'vmstore' volume

Actual results:
----------------
Cockpit limits the user to create bricks symmetrically on the all nodes. 
If 'sdb' is chosen, bricks are created on 'sdb' on all the nodes

Expected results:
-----------------
Asymmetric brick configuration should be allowed for users to create bricks on specific disks

Additional info:
-----------------
With this limitation in place, the users can solve this problem by editing the generated gdeploy configuration. But again this is error prone and hard to edit the generated gdeploy configuration file.

Comment 4 SATHEESARAN 2018-04-04 11:59:41 UTC
Tested with RHV-4.2.2-6 and cockpit-ovirt-dashboard-0.11.19

Bricks could be created asymmetrically on the 3 hosts. For eg. sdb from host1, sdc from host2, sde from host3 could be used for creating gluster volumes

Comment 5 Mugdha Soni 2018-04-17 06:18:48 UTC
Tested with the following-:

1. RedHat-release-virtualization-host-4.2-2.1.el7.x86_64
2. Cockpit-ovirt-dashboard-0.11.20-1

Bricks could be created asymmetrically on the 3 hosts. Following were the steps performed to test:-

1. Logged in to the cockpit UI and configured the brick tab.

2. Under subtab brick configuration , bricks were created asymmetrically.For eg. 
   sdb on host1 , sdc on host2 and sdc on host3 could be used for creating gluster 
   volume.
3. Gluster volumes were successfully created.

Comment 10 errata-xmlrpc 2018-11-08 05:37:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.