Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518334 - [UPDATES] resource_registry is not updated correctly
Summary: [UPDATES] resource_registry is not updated correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 12.0 (Pike)
Assignee: Lukas Bezdicka
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:15 UTC by Yurii Prokulevych
Modified: 2018-02-05 19:18 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-7.6.3-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:23:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 523802 None master: MERGED tripleo-common: Consume resource-registry in ProcessTemplatesAction (I1bb33796afa2c6d9a2bd7202e05075924f93da5d) 2017-11-30 18:25:51 UTC
OpenStack gerrit 524058 None stable/pike: NEW tripleo-common: Consume resource-registry in ProcessTemplatesAction (I1bb33796afa2c6d9a2bd7202e05075924f93da5d) 2017-11-30 18:25:47 UTC
Launchpad 1735330 None None None 2017-11-30 04:17:01 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Yurii Prokulevych 2017-11-28 16:15:15 UTC
Description of problem:
-----------------------
Puppet is running on overcloud nodes during init minor update.
    openstack overcloud update stack --init-minor-update \
        --container-registry-file docker.yaml 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-puppet-elements-7.0.1-1.el7ost.noarch
openstack-tripleo-common-containers-7.6.3-4.el7ost.noarch
python-tripleoclient-7.3.3-5.el7ost.noarch
puppet-tripleo-7.4.3-9.el7ost.noarch
openstack-tripleo-common-7.6.3-4.el7ost.noarch
openstack-tripleo-ui-7.4.3-4.el7ost.noarch
openstack-tripleo-validations-7.4.2-1.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-13.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-1.el7ost.noarch



How reproducible:
-----------------
100%

Steps to Reproduce:
1. Setup repos on oc nodes
2. Get latest docker images
3. Run:
    openstack overcloud update stack --init-minor-update \
        --container-registry-file docker.yaml

Comment 1 Amit Ugol 2017-11-29 09:12:00 UTC
The issue in this case is that puppet should not run at all during this stage, only when you run 'stack update --nodes ...'

Comment 2 Lukas Bezdicka 2017-11-29 15:19:04 UTC
The 'OS::TripleO::DeploymentSteps': 'OS::Heat::None' does not get set to none during init-minor-update and it runs Deployment_StepX tasks which means running puppet on nodes during the run. This is regression from previous state where init-minor-update just creates heat outputs.

Comment 8 Yurii Prokulevych 2017-12-12 14:34:12 UTC
Verified with openstack-tripleo-common-7.6.3-8.el7ost.noarch

Comment 11 errata-xmlrpc 2017-12-13 22:23:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.