Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518331 - Consider making defaultyes=True the default
Summary: Consider making defaultyes=True the default
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:10 UTC by Jan Niklas Hasse
Modified: 2017-11-29 12:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 12:31:23 UTC


Attachments (Terms of Use)

Description Jan Niklas Hasse 2017-11-28 16:10:18 UTC
When switching between apt, pacman and dnf, it always bothers me that I have to type "y" for dnf because the default is N. Of course I can add "defaultyes=True" to dnf.conf, but then I'm always cancelling prompts in newly set up Fedora instances (e.g. Docker) by mistake. I was wondering what you think about changing the default value.

Comment 1 Daniel Mach 2017-11-29 12:31:23 UTC
I'm sorry, but we cannot change expected behavior.

Comment 2 Jan Niklas Hasse 2017-11-29 12:35:33 UTC
Since most other package managers (e. g. apt, pacman, zypper) have yes as a default, isn't *that* the expected behavior?


Note You need to log in before you can comment on or make changes to this bug.