Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518330 - No event in timeline for the web console activity in RHV41
Summary: No event in timeline for the web console activity in RHV41
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Piotr Kliczewski
QA Contact: Angelina Nikiforova
URL:
Whiteboard:
Depends On:
Blocks: 1525059 1525583 1527083
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:09 UTC by thiebaut fischer
Modified: 2019-04-02 08:23 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1525059 1525583 1527083 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:13:04 UTC
Category: Bug
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
logs (deleted)
2017-12-04 09:26 UTC, thiebaut fischer
no flags Details
new logs (deleted)
2017-12-04 12:52 UTC, thiebaut fischer
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq-providers-ovirt pull 173 None None None 2017-12-08 16:07:42 UTC

Description thiebaut fischer 2017-11-28 16:09:49 UTC
Description of problem:

There is no event in the console activity category of the timeline of the VM ( provider RHV - infra)
Version-Release number of selected component (if applicable):
5.7.4.1.20171114202358_de8178a


How reproducible:

Always
Steps to Reproduce:
1. Open a web console of a VM  on provider RHV - infra
2. check its timeline, category "Console activity"

Actual results:
No events in that category


Expected results:
Events


Additional info:
Action was not yet tested on other providers and other versions
Appliance IP: 10.8.59.195
Noticed that in the DB (table event_streams), there is event_type: UNKNOW for those console activity.

event_type   message
UNKNOWN User admin@internal-authz got disconnected from VM test_timeline_thiebaut.
UNKNOWN User admin@internal-authz is connected to VM test_timeline_thiebaut.
UNKNOWN User admin@internal-authz initiated console session for VM test_timeline_thiebaut

Comment 4 Adam Grare 2017-11-29 13:39:35 UTC
Hey Oved, this looks like an issue with the ovirt event catcher

Comment 5 Oved Ourfali 2017-11-29 13:44:57 UTC
Thiebaut - can you please share both CFME and RHV logs?

Comment 6 thiebaut fischer 2017-12-04 09:26:13 UTC
Created attachment 1362603 [details]
logs

Comment 7 thiebaut fischer 2017-12-04 09:27:22 UTC
Hello, please, find in attachment the logs.The VM on which I made tests is called test-tfischer-timeline

Comment 8 Piotr Kliczewski 2017-12-04 12:10:29 UTC
Provided logs do not contain interaction with RHV provider. I see only Azure related logs. Please provide the logs to the correct provider.

Comment 9 Piotr Kliczewski 2017-12-04 12:29:05 UTC
This BZ looks like duplicate of BZ #1514509.

Comment 10 thiebaut fischer 2017-12-04 12:52:49 UTC
Created attachment 1362663 [details]
new logs

Comment 11 thiebaut fischer 2017-12-04 12:53:13 UTC
I updated the logs

Comment 12 Piotr Kliczewski 2017-12-04 13:16:46 UTC
It looks like we are missing handling of following events:

VM_SET_TICKET, VM_CONSOLE_CONNECTED and VM_CONSOLE_DISCONNECTED

it would be good to handle:

VM_SET_TICKET_FAILED


Note You need to log in before you can comment on or make changes to this bug.