Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518325 - oc set volumes not working for DaemonSets
Summary: oc set volumes not working for DaemonSets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.9.0
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 16:03 UTC by Rich Megginson
Modified: 2019-03-13 22:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Incorrect codec was used when patching resource. Consequence: Users were not able to set volume on a daemon set. Fix: Use proper codec when patching resources. Result: oc set volumes is working properly with daemon sets.
Clone Of:
Environment:
Last Closed: 2019-03-13 22:27:23 UTC


Attachments (Terms of Use)
oc set volumes with loglevel=8 (deleted)
2017-11-28 16:03 UTC, Rich Megginson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0403 None None None 2019-03-13 22:27:29 UTC
Github kubernetes kubernetes pull 53158 None None None 2017-11-28 16:04:45 UTC

Description Rich Megginson 2017-11-28 16:03:11 UTC
Created attachment 1359958 [details]
oc set volumes with loglevel=8

Description of problem:

    oc set volumes daemonset/logging-forward-fluentd --remove \
       --name=filebufferstorage

gives

    error: daemonsets/logging-forward-fluentd no kind "DaemonSet" is registered for version "apps/v1beta1"


Version-Release number of selected component (if applicable):

$ oc version
oc v3.8.0-alpha.0+fe4f498-286
kubernetes v1.8.1+0d5291c
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-11-161.ec2.internal:8443
openshift v3.8.0-alpha.0+fe4f498-286
kubernetes v1.8.1+0d5291c


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Juan Vallejo 2017-11-28 18:22:43 UTC
PR: https://github.com/openshift/origin/pull/17497

Comment 2 Xingxing Xia 2017-12-01 09:54:36 UTC
Tested in oc/OCP v3.8.0-alpha.0+af153e2-352 , `oc set volumes daemonset/...` works well in add/remove, regression test on other resource kinds (dc/deploy/rs) works well too
# oc set volume ds/hello-daemonset --add --name=v1 -m /data -n xxia-proj --config /root/xxia-test/admin.config
# oc set volume ds/hello-daemonset  
daemonsets/hello-daemonset
  empty directory as v1
    mounted at /data
# oc set volume daemonset/hello-daemonset --remove --name=v1 -n xxia-proj --config /root/xxia-test/admin.config
daemonset "hello-daemonset" updated

Currently PR doesn't go to OCP 3.8 (and OCP 3.8 env cannot be launched because it still misses some infra image in testing registry). Moving to MODIFIED

Comment 3 Xingxing Xia 2017-12-06 08:44:39 UTC
Verified in OCP v3.8.1, same result as above comment

Comment 6 errata-xmlrpc 2019-03-13 22:27:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0403


Note You need to log in before you can comment on or make changes to this bug.