Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151832 - CVS checkout really slow
Summary: CVS checkout really slow
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-22 18:52 UTC by Billy Biggs
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-04 18:49:42 UTC


Attachments (Terms of Use)
oprofile report (deleted)
2005-05-12 15:15 UTC, Anthony Green
no flags Details

Description Billy Biggs 2005-03-22 18:52:10 UTC
I am experimenting with using gcj/gij to run eclipse using the gcj packages from
the Fedora development repository.

One thing I have noticed when using gij or gcj-compiled eclipse is that CVS
checkouts seem really, really slow.  I am connecting to dev.eclipse.org
/home/eclipse as anonymous (pserver).  Is it possible that something at the
gcj/gij level is making network connections slow down?

Comment 1 Billy Biggs 2005-03-22 18:52:46 UTC
To clarify further, I am testing with eclipse I20050315-1100.

Comment 2 Andrew Overholt 2005-03-22 18:53:51 UTC
Moving to devel.  Assigning to me.

Comment 3 Andrew Overholt 2005-03-22 18:54:30 UTC
Really assigning to me.

Comment 4 Billy Biggs 2005-03-22 18:57:49 UTC
During checkout, the gij process is spinning the CPU.

Comment 5 Andrew Overholt 2005-03-22 19:00:52 UTC
This is CVS using ext, right?  It's over ssh?

Comment 6 Billy Biggs 2005-03-22 19:01:59 UTC
No, using pserver.

Comment 7 Anthony Green 2005-05-12 15:15:47 UTC
Created attachment 114297 [details]
oprofile report

I've attached an oprofile report of a pserver checkout of gnu-crypto.
I started profiling just as the cvs co started, and stopped as soon as it
finished.  
I haven't look at the report closely, other to note that we're spending the
vast majority of our time in the kernel - presumably waiting on stuff.	I also
don't understand why we're trying to load classes here.

Comment 8 Andrew Overholt 2005-05-18 13:41:01 UTC
I've been working on this 'cause it was really bugging me.  My test project was
gnu-crypto [1].  After fighting with oprofile and trying to figure out the cause
of the slow checkouts, I have now come to the conclusion that if we set the
compression level to 3 (or higher, I guess), checkout time is acceptable.  Since
I ran into similar problems with Sun's JVM (with gnu-crypto), I'm willing to bet
it's an upstream issue (or at least gnu-crypto exacerbates the issue).  I've
opened an Eclipse bug [2] to see if we can get the default compression set to 3
and if not, to see if there's a way we can set it in our builds.

[1]
:ext:anoncvs@savannah.gnu.org:/cvsroot/gnu-crypto
[2]
https://bugs.eclipse.org/bugs/show_bug.cgi?id=95697

Comment 9 Andrew Overholt 2005-06-06 15:11:06 UTC
I'd like to close this as NOTABUG because I get the same behaviour with our
native stuff as with Sun's JVM.

Thoughts?

Comment 10 Andrew Overholt 2005-10-11 11:21:12 UTC
I'm wondering if this was the same effect as bug 161483.  Billy/others, if you
get time, can you try the packages that will hit rawhide today (-15)?

Comment 11 Andrew Overholt 2005-10-20 15:28:46 UTC
I've noticed this myself now.  We do indeed take longer than the Sun JVM to
check things out of CVS regardless of compression level.

Comment 12 Andrew Haley 2006-03-13 13:28:38 UTC
Surely this one is now fixed.


Comment 13 Andrew Overholt 2006-03-13 15:04:47 UTC
I don't use the Sun JVM for much other than testing sometimes so I can't really
verify.  Ben, can you perhaps take a look at this?  Maybe we can get some data
out of the automated tests or something.

Comment 14 Igor Foox 2006-03-15 17:41:44 UTC
Blah blah.

Comment 15 Igor Foox 2006-03-15 17:42:03 UTC
(In reply to comment #10)
>I'm wondering if this was the same effect as bug 161483.  Billy/others, if you
>get time, can you try the packages that will hit rawhide today (-15)?
askldfjlsdf
sdfjsdfk


sfd

Comment 16 Ben Konrath 2006-10-04 18:44:46 UTC
I think we can close this bug now. Andrew, what do you think? 

Comment 17 Andrew Overholt 2006-10-04 18:49:42 UTC
Sure, and if checkout time bothers people, we can re-open.

Closing.


Note You need to log in before you can comment on or make changes to this bug.