Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518295 - Cockpit should configure engine volume always as replica 3 volume
Summary: Cockpit should configure engine volume always as replica 3 volume
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.0
Hardware: x86_64
OS: Linux
high
low
Target Milestone: ---
: ---
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1518293
TreeView+ depends on / blocked
 
Reported: 2017-11-28 15:01 UTC by SATHEESARAN
Modified: 2018-01-23 10:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1518293
Environment:
Last Closed: 2018-01-23 10:32:24 UTC
oVirt Team: Gluster


Attachments (Terms of Use)

Description SATHEESARAN 2017-11-28 15:01:39 UTC
+++ This bug was initially created as a clone of Bug #1518293 +++

Description of problem:
-----------------------
Self-hosted Engine (SHE) is the Virtual machine running RHV manager application, that is hosted on one of the application VM itself. SHE should be highly available, so that the data center and its components are managed.

Replica 3 volume provides high availability compared to arbiter volume. That's the reason, engine volume is always configured with replica 3 volume.

But cockpit provides the option for the user to configure hosted-engine volume as arbiter volume too. This should **not** be allowed


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.9-1.el7ev.noarch

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Kickstart RHHI deployment using recommended interface of cockpit

Actual results:
----------------
Engine volume could be configured as arbiter volume. There is arbiter checkbox that is available near to engine volume list item

Expected results:
-----------------
Engine volume should always be replica 3 volume. Arbiter checkbox near to engine volume is not required.
hh

Comment 1 Sahina Bose 2017-12-04 06:53:52 UTC
(In reply to SATHEESARAN from comment #0)
> +++ This bug was initially created as a clone of Bug #1518293 +++
> 
> Description of problem:
> -----------------------
> Self-hosted Engine (SHE) is the Virtual machine running RHV manager
> application, that is hosted on one of the application VM itself. SHE should
> be highly available, so that the data center and its components are managed.
> 
> Replica 3 volume provides high availability compared to arbiter volume.
> That's the reason, engine volume is always configured with replica 3 volume.
> 
> But cockpit provides the option for the user to configure hosted-engine
> volume as arbiter volume too. This should **not** be allowed

Why is this a hard requirement. Though replica 3 + arbiter does not provide as much availability as a replica 3, it's also an option for providing HA for VMs.
We do default the engine volume to replica 3 - I'm not so sure about disabling this option completely. Would a warning do?

> 
> 
> Version-Release number of selected component (if applicable):
> -------------------------------------------------------------
> cockpit-ovirt-dashboard-0.10.9-1.el7ev.noarch
> 
> How reproducible:
> -----------------
> Always
> 
> Steps to Reproduce:
> --------------------
> 1. Kickstart RHHI deployment using recommended interface of cockpit
> 
> Actual results:
> ----------------
> Engine volume could be configured as arbiter volume. There is arbiter
> checkbox that is available near to engine volume list item
> 
> Expected results:
> -----------------
> Engine volume should always be replica 3 volume. Arbiter checkbox near to
> engine volume is not required.
> hh

Comment 2 SATHEESARAN 2018-01-23 10:32:24 UTC
(In reply to Sahina Bose from comment #1)
> (In reply to SATHEESARAN from comment #0)
> > +++ This bug was initially created as a clone of Bug #1518293 +++
> > 
> > Description of problem:
> > -----------------------
> > Self-hosted Engine (SHE) is the Virtual machine running RHV manager
> > application, that is hosted on one of the application VM itself. SHE should
> > be highly available, so that the data center and its components are managed.
> > 
> > Replica 3 volume provides high availability compared to arbiter volume.
> > That's the reason, engine volume is always configured with replica 3 volume.
> > 
> > But cockpit provides the option for the user to configure hosted-engine
> > volume as arbiter volume too. This should **not** be allowed
> 
> Why is this a hard requirement. Though replica 3 + arbiter does not provide
> as much availability as a replica 3, it's also an option for providing HA
> for VMs.
> We do default the engine volume to replica 3 - I'm not so sure about
> disabling this option completely. Would a warning do?


This was already discussed in the bug triage.

SHE requires to be highly available, but arbitrated replicate volume is highly available, but not on par with replica 3 volume. But still its a viable option for the users to make use of arbitrated volume.

Based on the above discussion considering this bug to be CLOSED


Note You need to log in before you can comment on or make changes to this bug.