Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518293 - Cockpit should configure engine volume always as replica 3 volume
Summary: Cockpit should configure engine volume always as replica 3 volume
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhi-1.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1518295
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 14:58 UTC by SATHEESARAN
Modified: 2017-12-18 05:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518295 (view as bug list)
Environment:
Last Closed: 2017-12-15 12:43:37 UTC


Attachments (Terms of Use)

Description SATHEESARAN 2017-11-28 14:58:11 UTC
Description of problem:
-----------------------
Self-hosted Engine (SHE) is the Virtual machine running RHV manager application, that is hosted on one of the application VM itself. SHE should be highly available, so that the data center and its components are managed.

Replica 3 volume provides high availability compared to arbiter volume. That's the reason, engine volume is always configured with replica 3 volume.

But cockpit provides the option for the user to configure hosted-engine volume as arbiter volume too. This should **not** be allowed


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.9-1.el7ev.noarch

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Kickstart RHHI deployment using recommended interface of cockpit

Actual results:
----------------
Engine volume could be configured as arbiter volume. There is arbiter checkbox that is available near to engine volume list item

Expected results:
-----------------
Engine volume should always be replica 3 volume. Arbiter checkbox near to engine volume is not required.
hh

Comment 1 SATHEESARAN 2017-12-05 17:49:08 UTC
With the bug triage meeting happened on Dec 5,2017 , Sahina has shared the thoughts about arbitrated replicate volume however lacks high-availability which is known.

Later, if there are any customers that asks for hosted-engine VM running on arbitrated replicate volume, after knowing the limitation of such volume, as their infrastructure compels them (probably one lean-storage node ), we would be devoid of supporting this case.

Considering that QE defers that this change is not required, and so this bug could be closed.

@Sahina, please acknowledge the same, and could you CLOSE this bug ?

Comment 2 Sahina Bose 2017-12-15 12:43:37 UTC
Yes, closing this. Also considering the fact that we have support for single node RHHI deployment too - the replica 3 enforcement will not work in that case as well.


Note You need to log in before you can comment on or make changes to this bug.