Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518289 - [RFE] Installing katello-ca-consumer should not restart docker, but notify of required action
Summary: [RFE] Installing katello-ca-consumer should not restart docker, but notify of...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Certificates
Version: 6.2.12
Hardware: x86_64
OS: Linux
unspecified
high with 2 votes vote
Target Milestone: 6.3
Assignee: Stephen Benjamin
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 14:57 UTC by ktbzimm
Modified: 2018-12-06 20:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 13:36:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1127 None None None 2018-04-13 13:36:19 UTC
Foreman Issue Tracker 19271 None None None 2018-02-15 02:35:49 UTC

Description ktbzimm 2017-11-28 14:57:19 UTC
Description of problem:
RHEL 7.4 client
During the process of registering a system to Satellite, installing katello-ca-consumer-latest.noarch.rpm runs /usr/bin/katello-rhsm-consumer on postinstall.
This script automatically restarts Docker.
This unexpected behavior is a surprise to anyone who has Docker containers running on the system.

Version-Release number of selected component (if applicable):
satellite-6.2.12-6.0.el7sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh http://<satellite host>/pub/katello-ca-consumer-latest.noarch.rpm
2.
3.

Actual results:
Katello gets installed, but restarts the Docker service along the way.

Expected results:
Katello gets installed, leaving Docker service alone.

Additional info:

Comment 1 Craig Donnelly 2017-12-01 16:56:54 UTC
Hello,

The reason that the katello-ca-consumer script restarts docker is due to the fact that we are importing the CA into RHEL and need to make that certificate available for use with the docker services and the systems hosted by it.

I think it would be logical for us to include some better documentation around that fact that this is going to happen, but we need to ensure the services is restarted so that it can properly use entitlement information derived from the Satellite.

Comment 2 ktbzimm 2017-12-07 18:33:43 UTC
Hi Craig,

I get what you're saying.  However, this process is automated for us, and for installation of katello to yank our Docker instances out from under us on production servers is very disconcerting and problematic.  Could I propose instead that the Docker restart is removed, and documentation include a reference to restarting Docker at the admin's earliest convenience?

Thanks!

Comment 3 Craig Donnelly 2017-12-08 18:54:29 UTC
Thank you, and I understand your position.

We agree that this action probably should not be taken on your behalf, so I am converting this to an RFE for the katello-bootstrap package (via certificates) and we are proposing that the path forward be to detect a running docker service on the host of install, and notify via terminal/cli where the action occurs that a service restart will be required to consume entitlements for those hosts.

Comment 4 dlbewley 2018-02-14 22:41:23 UTC
A very strong +1 on this one. 

I just spent a few hours trying to figure out how our Satellite registration playbook caused an OpenShift outage. :(

Comment 5 Aaron Russo 2018-02-15 00:03:43 UTC
It appears this was fixed in upstream Katello, Satellite just needs to catch up.

https://github.com/theforeman/puppet-certs/pull/156
https://github.com/theforeman/puppet-certs/blob/master/templates/rhsm-katello-reconfigure.erb

If we're not moving to a sufficient version of Katello in 6.3, then it should be backported.

Comment 6 pm-sat@redhat.com 2018-02-15 03:06:02 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 7 pm-sat@redhat.com 2018-02-15 03:06:05 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/19271 has been resolved.

Comment 13 errata-xmlrpc 2018-04-13 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1127


Note You need to log in before you can comment on or make changes to this bug.