Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518277 - Eternal spinner in Red Hat Insights/Actions (Provide additional error context)
Summary: Eternal spinner in Red Hat Insights/Actions (Provide additional error context)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Insights
Classification: Red Hat
Component: CloudForms Integration
Version: unspecified
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Jeff Needle
QA Contact: Jeff Needle
URL:
Whiteboard: testathon
: 1518787 1531114 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 14:38 UTC by Dmitry Misharov
Modified: 2018-12-11 19:13 UTC (History)
14 users (show)

Fixed In Version: rh-ruby23-rubygem-redhat_access_cfme-2.0.2-1.el7cf, rh-ruby23-rubygem-redhat_access_lib-1.1.4-1.el7cf
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 19:13:07 UTC


Attachments (Terms of Use)
production.log (deleted)
2017-11-28 14:38 UTC, Dmitry Misharov
no flags Details
Insights help screen (deleted)
2018-01-08 14:47 UTC, Lindani Phiri
no flags Details

Description Dmitry Misharov 2017-11-28 14:38:35 UTC
Created attachment 1359919 [details]
production.log

Description of problem:
Red Hat Insights/Actions shows only spinner 

Version-Release number of selected component (if applicable):
5.9.0.11.20171127204214_e316988 

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Red Hat Insights/Actions.

Actual results:
There is the only spinner.

Comment 3 Marianne Feifer 2017-11-28 19:33:57 UTC
I'm not sure which Insights component this should go to.  The issue was found during a CloudForms Testathon.

Comment 4 Christian Jung 2017-11-29 15:01:42 UTC
*** Bug 1518787 has been marked as a duplicate of this bug. ***

Comment 5 Jonathan Newton 2017-11-29 18:35:46 UTC
So the Insights team looked at this and Ian Hands determined that the issue was because the system wasn't registered to rhsm which is a requirement. Once you register, Insights works fine. Closing as not a bug.

Comment 6 Christian Jung 2017-11-29 19:54:45 UTC
IMHO this is still a bug, because there should be some explanation to why this happens. At least some text or a link to the Insights documentation, anything to inform the user about the root cause is better than just showing a load screen.

Comment 7 Jonathan Newton 2017-11-29 19:59:32 UTC
Fair point and I agree that we should be able to do a better job informing the user about what's wrong. When our main tech lead for CF integration gets back from PTO, we can talk with him about what changes we can make.

Comment 8 Jan Krocil 2017-11-30 10:01:31 UTC
This actually affects all the sections under Red Hat Insights. They report "There was an error retrieving data." but still display forms with a spinner...

Can we display something like "The appliance must be registered to RHSM to leverage the Red Hat Insights feature. Please see docs here: <link>." or something like that, more user friendly, than a spinner and a broken form?

Thanks

Comment 9 Loic Avenel 2017-11-30 10:07:18 UTC
From a User Experience this is not good, we should provider meaningful information for User and best some guidance how to remediate it.

Comment 10 Lindani Phiri 2018-01-08 14:39:30 UTC
*** Bug 1531114 has been marked as a duplicate of this bug. ***

Comment 11 Lindani Phiri 2018-01-08 14:47:41 UTC
Created attachment 1378561 [details]
Insights help screen

Comment 12 Lindani Phiri 2018-01-08 14:48:58 UTC
Help screen readded (see attachment). 
This will be shown when Insights configuration is incomplete.

Comment 13 Satoe Imaishi 2018-01-12 14:23:20 UTC
The new RPMs are included in CFME 5.9.0.16 build.

Comment 14 Dmitry Misharov 2018-09-25 06:41:02 UTC
Verified on CFME 5.9 and 5.10. There is no infinite spinner on non-registered systems.


Note You need to log in before you can comment on or make changes to this bug.