Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518249 - SSA on Ubuntu instance on Azure provider throws error in evm.log
Summary: SSA on Ubuntu instance on Azure provider throws error in evm.log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Hui Song
QA Contact: Satyajit Bulage
URL:
Whiteboard: smartstate:azure:instance
Depends On:
Blocks: 1530726
TreeView+ depends on / blocked
 
Reported: 2017-11-28 13:43 UTC by Satyajit Bulage
Modified: 2018-06-21 20:34 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1530726 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:34:43 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Satyajit Bulage 2017-11-28 13:43:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):5.9.0.11.20171127204214_e316988


How reproducible:100%


Steps to Reproduce:
1. Add Azure provider 
2. Perform SSA on Ubuntu instance.
3.

Actual results: SSA scan Ubuntu instance but gives error in evm.log


Expected results: While running SSA it should not throw any error in evm.log


Additional info:

Comment 8 Hui Song 2017-11-30 16:55:08 UTC
Satyajit,

Thank you for allowing me to use your appliance. The cause is clear now. In that Ubuntu instance, there are 3 physical volumes. The partition types of two of them have special characters:

irb(main):190:0> physicalVolumes[0].partType
=> "\xAF=\xC6\x0F\x83\x84rG\x8Ey=i\xD8G}\xE4"
irb(main):191:0> physicalVolumes[1].partType
=> "Hah!IdontNeedEFI"
irb(main):192:0> physicalVolumes[2].partType
=> "(s*\xC1\x1F\xF8\xD2\x11\xBAK\x00\xA0\xC9>\xC9;"

Now I am working on the fix, so still need your environment for a while.

Comment 10 CFME Bot 2017-12-15 15:28:16 UTC
New commit detected on ManageIQ/manageiq-gems-pending/master:
https://github.com/ManageIQ/manageiq-gems-pending/commit/e612f39403e01e1b43b3acfb95c1501febeaf1c6

commit e612f39403e01e1b43b3acfb95c1501febeaf1c6
Author:     hsong-rh <hsong@redhat.com>
AuthorDate: Fri Dec 1 10:18:06 2017 -0500
Commit:     hsong-rh <hsong@redhat.com>
CommitDate: Fri Dec 1 10:18:06 2017 -0500

    Add valid_encoding checking before insert into xml object.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1518249

 lib/gems/pending/util/xml/miq_rexml.rb | 4 ++--
 lib/gems/pending/util/xml/xml_utils.rb | 6 ++++++
 2 files changed, 8 insertions(+), 2 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.