Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518213 - Creation and deletion of routers raises traceback errors in l3-agent.log - DB error
Summary: Creation and deletion of routers raises traceback errors in l3-agent.log - DB...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Brian Haley
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 12:37 UTC by Toni Freger
Modified: 2018-02-14 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-14 15:38:35 UTC


Attachments (Terms of Use)
server.log (deleted)
2017-11-28 12:37 UTC, Toni Freger
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1562887 None None None 2018-02-07 18:37:55 UTC

Description Toni Freger 2017-11-28 12:37:16 UTC
Created attachment 1359837 [details]
server.log

Description of problem:
Error traces appears during creation and deletion of routers via openstack-rally task.

Version-Release number of selected component (if applicable):
openstack-neutron-2015.1.4-26.el7ost.noarch

How reproducible:
I've ran rally benchmark test, creation and deletion of 30 routers, 3 concurrent iteration.
In spite of errors, all routers created deleted successfully.


Test could be found here - https://github.com/openstack/rally/blob/793735c152a573d72391a8ac21e2d908b631195a/samples/tasks/scenarios/neutron/create-and-delete-routers.json



2017-11-26 06:11:58.057 13833 ERROR oslo_messaging._drivers.common [req-0960e688-2e48-4305-8782-c12a8f49859f ] Returning exception No more IP addresses available on network 3eed36f6-0dfc-43f5-bc9d-c5f44f363e14. to caller
2017-11-26 06:11:58.057 13833 ERROR oslo_messaging._drivers.common [req-0960e688-2e48-4305-8782-c12a8f49859f ] ['Traceback (most recent call last):\n', '  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 142, in _dispatch_and_reply\n    executor_callback))\n', '  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 186, in _dispatch\n    executor_callback)\n', '  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 130, in _do_dispatch\n    result = func(ctxt, **new_args)\n', '  File "/usr/lib/python2.7/site-packages/neutron/api/rpc/handlers/dhcp_rpc.py", line 309, in create_dhcp_port\n    return self._port_action(plugin, context, port, \'create_port\')\n', '  File "/usr/lib/python2.7/site-packages/neutron/api/rpc/handlers/dhcp_rpc.py", line 96, in _port_action\n    {"action": action, "net_id": net_id, \'reason\': e})\n', '  File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 85, in __exit__\n    six.reraise(self.type_, self.value, self.tb)\n', '  File "/usr/lib/python2.7/site-packages/neutron/api/rpc/handlers/dhcp_rpc.py", line 73, in _port_action\n    return plugin.create_port(context, port)\n', '  File "/usr/lib/python2.7/site-packages/oslo_db/api.py", line 131, in wrapper\n    return f(*args, **kwargs)\n', '  File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/plugin.py", line 1009, in create_port\n    result, mech_context = self._create_port_db(context, port)\n', '  File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/plugin.py", line 983, in _create_port_db\n    result = super(Ml2Plugin, self).create_port(context, port)\n', '  File "/usr/lib/python2.7/site-packages/neutron/db/db_base_plugin_v2.py", line 1862, in create_port\n    ips = self._allocate_ips_for_port(context, port)\n', '  File "/usr/lib/python2.7/site-packages/neutron/db/db_base_plugin_v2.py", line 574, in _allocate_ips_for_port\n    p[\'mac_address\'])\n', '  File "/usr/lib/python2.7/site-packages/neutron/db/db_base_plugin_v2.py", line 488, in _allocate_fixed_ips\n    result = self._generate_ip(context, subnets)\n', '  File "/usr/lib/python2.7/site-packages/neutron/db/db_base_plugin_v2.py", line 188, in _generate_ip\n    return NeutronDbPluginV2._try_generate_ip(context, subnets)\n', '  File "/usr/lib/python2.7/site-packages/neutron/db/db_base_plugin_v2.py", line 225, in _try_generate_ip\n    raise n_exc.IpAddressGenerationFailure(net_id=subnets[0][\'network_id\'])\n', 'IpAddressGenerationFailure: No more IP addresses available on network 3eed36f6-0dfc-43f5-bc9d-c5f44f363e14.\n']
2017-11-26 06:12:00.512 13833 ERROR oslo_db.api [req-0e3f4e8d-6ae3-4763-8287-d529cce4a76d ] DB error.
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api Traceback (most recent call last):
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api   File "/usr/lib/python2.7/site-packages/oslo_db/api.py", line 131, in wrapper
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api     return f(*args, **kwargs)
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api   File "/usr/lib/python2.7/site-packages/neutron/db/api.py", line 79, in wrapper
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api     raise os_db_exception.RetryRequest(e)
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api RetryRequest
2017-11-26 06:12:00.512 13833 TRACE oslo_db.api

Comment 1 Brian Haley 2018-02-07 18:39:18 UTC
This looks like the bug I linked, which does not have a fix yet.


Note You need to log in before you can comment on or make changes to this bug.