Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518189 - [abrt] gnome-shell: raise(): gnome-shell killed by SIGTRAP ("Too many open files", open FDs relate to wallpaper, may be 'Random Walls' extension)
Summary: [abrt] gnome-shell: raise(): gnome-shell killed by SIGTRAP ("Too many open fi...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:56efaa338ff91e520f5cf7a9de6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 11:46 UTC by jun
Modified: 2019-02-11 11:19 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-03 23:48:26 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-28 11:46 UTC, jun
no flags Details
File: open_fds (deleted)
2017-11-28 11:46 UTC, jun
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1506435 None None None Never
Red Hat Bugzilla 1513492 None None None Never
Red Hat Bugzilla 1516553 None None None Never

Description jun 2017-11-28 11:46:00 UTC
Version-Release number of selected component:
gnome-shell-3.26.2-1.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: raise
executable:     /usr/bin/gnome-shell
journald_cursor: s=f7c4202e5e48451092604b36df4c49b7;i=94422;b=245285af7fad4d5bbcda7aa08bfef181;m=45c04e4;t=55f09879c4c06;x=7cc9ddc14cc215a0
kernel:         4.13.15-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #0 raise at ../sysdeps/unix/sysv/linux/raise.c:51
 #1 dump_gjs_stack_on_signal_handler at ../src/main.c:372

This is a private, duplicate bug report of bug 1517009. The report has been created because Bugzilla cannot grant access to a comment for a specific group.

Comment 1 jun 2017-11-28 11:46:05 UTC
Created attachment 1359793 [details]
File: backtrace

Comment 2 jun 2017-11-28 11:46:06 UTC
Created attachment 1359794 [details]
File: cgroup

Comment 3 jun 2017-11-28 11:46:08 UTC
Created attachment 1359795 [details]
File: core_backtrace

Comment 4 jun 2017-11-28 11:46:09 UTC
Created attachment 1359796 [details]
File: cpuinfo

Comment 5 jun 2017-11-28 11:46:11 UTC
Created attachment 1359797 [details]
File: dso_list

Comment 6 jun 2017-11-28 11:46:12 UTC
Created attachment 1359798 [details]
File: environ

Comment 7 jun 2017-11-28 11:46:13 UTC
Created attachment 1359799 [details]
File: limits

Comment 8 jun 2017-11-28 11:46:15 UTC
Created attachment 1359800 [details]
File: maps

Comment 9 jun 2017-11-28 11:46:17 UTC
Created attachment 1359801 [details]
File: mountinfo

Comment 10 jun 2017-11-28 11:46:19 UTC
Created attachment 1359802 [details]
File: open_fds

Comment 11 jun 2017-11-28 11:46:20 UTC
Created attachment 1359803 [details]
File: proc_pid_status

Comment 12 jun 2017-11-28 11:46:21 UTC
Created attachment 1359804 [details]
File: var_log_messages

Comment 13 jun 2017-11-28 11:46:23 UTC

*** This bug has been marked as a duplicate of bug 1517009 ***

Comment 14 Adam Williamson 2017-12-15 02:10:49 UTC
This does not in fact look like a duplicate of 1517009 or 1510059. This seems to be another case of "Too many open files", like #1516553 and #1513492. The error here appears to be "Creating pipes for GWakeup: Too many open files", which looks the same as #1516553. I'm still not sure if they can be truly considered dupes, though, so leaving open for now.

Comment 15 Adam Williamson 2017-12-15 02:15:54 UTC
*** Bug 1520228 has been marked as a duplicate of this bug. ***

Comment 16 Adam Williamson 2017-12-15 18:30:44 UTC
So, using the debugging tip Ray provided in https://bugzilla.redhat.com/show_bug.cgi?id=1516553#c15 (and modifying it a bit), we see:

    252 anon_inode:[timerfd]
    269 /home/jun/Pictures/Wallpapers
    299 /home/jun/Pictures/Wallpapers/bak

so we do have the leak identified in that bug active here too (252 open fds for timerfd), but we also have something else going on - open fds for your wallpapers directories. The update to fix the timerfd bug - https://bodhi.fedoraproject.org/updates/FEDORA-2017-7758521ad4 - should help you, but it may not fully solve the problem. Can you try it and see? Do you have any extensions that deal with wallpapers at all, that could be involved here?

Ray, any ideas on this one? Thanks!

Comment 18 Adam Williamson 2017-12-16 02:23:39 UTC
*** Bug 1499587 has been marked as a duplicate of this bug. ***

Comment 19 jun 2017-12-16 02:31:26 UTC
i have an extension about that is 
https://extensions.gnome.org/extension/1000/random-walls/

if i can be of any help to you.

Comment 20 Adam Williamson 2017-12-16 02:55:20 UTC
Yes, in fact, that could very well be the cause: I just came across another crash report with similar symptoms where the reporter had the same extension enabled - https://bugzilla.redhat.com/show_bug.cgi?id=1506435 . I filed an upstream issue for this - https://github.com/rodakorn/randwall/issues/34 . Can you try disabling that extension and see if it makes the crashes go away, if they're happening frequently? Thanks!

Comment 21 jun 2017-12-16 03:47:03 UTC
OK.
i will try to disable that extension a couple of week and report again in this year.

Comment 22 jun 2017-12-20 06:54:26 UTC
i had down gnome-shell and report below.(it may be another reason)

https://bugzilla.redhat.com/show_bug.cgi?id=1517433

btw, i can NOT access below url (not authorized)

Is it related issue ?
https://bugzilla.redhat.com/show_bug.cgi?id=1506435

Comment 23 Adam Williamson 2017-12-20 19:38:22 UTC
The other crash you're hitting is different, yes. As the duplication closures indicate, it's https://bugzilla.redhat.com/show_bug.cgi?id=1469129 . Not the same as this at all.

"btw, i can NOT access below url (not authorized)"

yeah, lots of the crash reports we're dealing with here are set to private because abrt defaults to reporting private bugs any time it thinks it saw sensitive information in the bug report data, and it's *way* too sensitive; it will assume any occurrence of 'key' or 'user' in the data could indicate sensitive information, for instance. So bug reports often wind up getting set private when they don't need to be. I'm trying to get the important ones marked as *not* private, but it requires me to check through the attachments carefully and (ideally) contact the reporter, so it's slow.

Comment 24 Adam Williamson 2017-12-20 19:42:22 UTC
On that note...do you mind if I mark this report as public, and mark the backtrace and open_fds attachments as public, but leave the other attachments private? I'm pretty sure there's no personal data in any of the attachments, but just opening up those two should be all people need to understand the bug.

Comment 25 jun 2017-12-29 16:14:44 UTC
I will report again as I promised.
I spent a couple week that removed random-walls extension and I had never killed gnome-shell by this issue. I think effective was.

Comment 26 Adam Williamson 2018-01-03 23:48:26 UTC
OK, thanks. On that basis I'll close this as UPSTREAM, indicating it's an issue in the extension, and thus we can't fix it in Fedora - it needs to be fixed by the extension author upstream. Thanks!

Comment 27 Philipp Bobek 2018-03-23 11:06:14 UTC
*** Bug 1559825 has been marked as a duplicate of this bug. ***

Comment 28 zimon 2018-03-30 16:19:26 UTC
*** Bug 1562420 has been marked as a duplicate of this bug. ***

Comment 29 zimon 2018-03-30 16:27:56 UTC
I've had a few of these crashes which bugzilla now when reported 1562420 thinks is a duplicate of this now CLOSED UPSTREAM bug.
However, I have never used random-walls extension, so hardly that is a reason for my gnome-shell crashes.

Comment 30 redguy41 2018-04-09 14:00:49 UTC
*** Bug 1565161 has been marked as a duplicate of this bug. ***

Comment 31 Ken 2018-04-09 16:13:05 UTC
*** Bug 1565216 has been marked as a duplicate of this bug. ***

Comment 32 Douglas Kaip 2018-04-09 17:25:18 UTC
*** Bug 1565238 has been marked as a duplicate of this bug. ***

Comment 33 Joel Stienlet 2018-04-16 00:02:15 UTC
I don't use this "random-walls" extension either, but report-cli detected my bug as a duplicate of this one.

Comment 34 Rik van Riel 2018-04-28 01:36:39 UTC
*** Bug 1572829 has been marked as a duplicate of this bug. ***

Comment 35 Vincenzo Luongo 2018-05-10 11:17:17 UTC
Similar problem has been detected:

opena  torcs game and crash after 1 minutes

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: raise
executable:     /usr/bin/gnome-shell
journald_cursor: s=f437cb100a7645e6a861f4cdb121bb69;i=de66;b=ca1ff82c12e342cd8a9678ab7bb22aad;m=2c80b11af;t=56bd7e373b37a;x=1d0b87d005d60bba
kernel:         4.14.6-300.fc27.x86_64
package:        gnome-shell-3.26.2-5.fc27
reason:         gnome-shell killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 36 Andrey 2018-05-12 03:18:43 UTC
Similar problem has been detected:

VLC crashed me

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: raise
executable:     /usr/bin/gnome-shell
journald_cursor: s=a2c7ec1885d74083a4fa5a1e34d765f0;i=5971;b=a264d3f2af1745a2a87e99bc5a49838c;m=c3c1e922a;t=56bf983d348a9;x=6e263d5100505e92
kernel:         4.16.6-202.fc27.x86_64
package:        gnome-shell-3.26.2-5.fc27
reason:         gnome-shell killed by SIGTRAP
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 37 zimbardorichter 2018-06-14 08:29:58 UTC
Similar problem has been detected:

I had already pluged in a monitor on my mini-display port of my laptop and wanted to add another monitor (AOC) on the HDMI port.
First there was no reaction at all and I unplugged it again, then in, then out, then in and I waited for a couple of seconds.
The monitor seemed to have been noticed but then I was thrown back to the login screen...

There cable might be a bit broken or the port is a bit lose because sometimes it doesn't work continuesly after plugin.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: raise
executable:     /usr/bin/gnome-shell
journald_cursor: s=7f5c42992a8e4a8b87b1bcba09adb589;i=2f9c3;b=ddcafd8da16a407e98052bb23de3fd9e;m=259e13c7c4;t=56e9516e3c58a;x=ce5ed294e219a7ab
kernel:         4.16.13-200.fc27.x86_64
package:        gnome-shell-3.26.2-5.fc27
reason:         gnome-shell killed by SIGFPE
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 38 Ashon 2018-10-26 20:33:25 UTC
*** Bug 1643643 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.