Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518167 - [NMCI] nmtui cannot create open network profile
Summary: [NMCI] nmtui cannot create open network profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 11:14 UTC by Vladimir Benes
Modified: 2018-04-10 13:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:34:16 UTC


Attachments (Terms of Use)
[PATCH] tui: fix creation of open Wi-Fi connections (deleted)
2017-11-30 16:30 UTC, Beniamino Galvani
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0778 None None None 2018-04-10 13:35:11 UTC

Description Vladimir Benes 2017-11-28 11:14:07 UTC
Description of problem:
when I try to create open wireless network via nmtui I end up with error:
Unable to add new connection: 802-11-wireless-security.key-mgmt: property is missing.

Version-Release number of selected component (if applicable):
1.10

How reproducible:
always

Steps to Reproduce:
    * Prepare new connection of type "Wi-Fi" named "wifi"
    * Set "SSID" field to "qe-open"
    * Confirm the connection settings
    Then "ESSID=(\"qe-open\"|qe-open)" is visible with command "cat /etc/sysconfig/network-scripts/ifcfg-wifi"
    Then "DEVICE" is not visible with command "cat /etc/sysconfig/network-scripts/ifcfg-wifi"
    Then "TYPE=Wireless" is visible with command "cat /etc/sysconfig/network-scripts/ifcfg-wifi"
    Then "inet 10." is visible with command "ip a s wlan0" in "30" seconds

Actual results:
error

Expected results:
no error

Additional info:

Comment 1 Beniamino Galvani 2017-11-30 16:30:29 UTC
Created attachment 1360991 [details]
[PATCH] tui: fix creation of open Wi-Fi connections

Comment 2 Thomas Haller 2017-11-30 17:11:26 UTC
lgtm

Comment 5 Vladimir Benes 2017-12-13 12:33:48 UTC
working well again

Comment 8 errata-xmlrpc 2018-04-10 13:34:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0778


Note You need to log in before you can comment on or make changes to this bug.