Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518147 - Unhelpful errors after running ipa pkinit-status on a server with pkinit disabled
Summary: Unhelpful errors after running ipa pkinit-status on a server with pkinit disa...
Keywords:
Status: CLOSED DUPLICATE of bug 1502663
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 10:31 UTC by Aneta Šteflová Petrová
Modified: 2018-02-15 13:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-15 13:54:22 UTC


Attachments (Terms of Use)

Description Aneta Šteflová Petrová 2017-11-28 10:31:36 UTC
Description of problem:

When I run $ ipa pkinit-status on a RHEL 7.4 server with PKINIT disabled, I get these errors: 

With an admin ticket:

    ipa: ERROR: No valid Negotiate header in server response

Without an admin ticket:

    ipa: ERROR: an internal error has occurred


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

The message are not very helpful.

Expected results:

More helpful messages, ideally saying that PKINIT is disabled.


Additional info:

Comment 2 Florence Blanc-Renaud 2017-11-29 09:36:04 UTC
This issue has the same root cause as BZ #1502663, which was fixed in ipa-4.5.4-1.el7 (rhel 7.5) but not backported to rhel 7.4

Comment 3 Florence Blanc-Renaud 2017-12-06 13:23:34 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7144

Comment 4 Petr Vobornik 2017-12-12 17:02:02 UTC
Do I understand it correctly that it is fixed in ipa-4.5.4-1.el7 ? I.e. this error is only in 7.4. If so I'd close the bug as dup of 1502663.

Comment 5 Florence Blanc-Renaud 2017-12-12 17:28:16 UTC
Yes, you understand correctly.

Comment 6 Florence Blanc-Renaud 2018-02-15 13:54:22 UTC

*** This bug has been marked as a duplicate of bug 1502663 ***


Note You need to log in before you can comment on or make changes to this bug.