Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518079 - While adding subnet through normal user admin tenant is visible
Summary: While adding subnet through normal user admin tenant is visible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Libor Pichler
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1535062
TreeView+ depends on / blocked
 
Reported: 2017-11-28 07:41 UTC by Imaan
Modified: 2018-06-21 20:26 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1535062 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:26:23 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)
Image describe the issue (deleted)
2017-11-28 07:41 UTC, Imaan
no flags Details
db dump (deleted)
2017-12-07 14:41 UTC, Yuri Rudman
no flags Details

Description Imaan 2017-11-28 07:41:36 UTC
Created attachment 1359704 [details]
Image describe the issue

Description of problem:

While adding subnet through normal user admin tenant is visible in cloud tenant drop down list 

Version-Release number of selected component (if applicable):

5.8.2.3.20171016155816_aaec796

How reproducible:

Always

Steps to Reproduce:

1. Login to CloudForms Operational Portal through normal user

2. Navigate to Networks -> Subnets -> Configuration -> Add a new Cloud Tenant -> Specify the Network manager from the drop down list 

3. Check the Cloud Tenant drop down list. The admin tenant is visible under the list.


Actual results:

The admin tenant is visible under the drop down list while adding subnet through normal user.


Expected results:

The list should not display admin tenant.

Additional info:

We have checked this behavior on cloudforms 4.6 beta 
version, the issue is not reproducible there on the latest version apparently.

Comment 5 Yuri Rudman 2017-12-07 14:41:48 UTC
Created attachment 1364338 [details]
db dump

db dump


Note You need to log in before you can comment on or make changes to this bug.