Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518075 - [prod] Error will occur if add an VAT number before confirming the subscription
Summary: [prod] Error will occur if add an VAT number before confirming the subscription
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Accounts and Billing
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: Bing Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 07:25 UTC by Bing Li
Modified: 2017-11-28 07:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 07:49:31 UTC


Attachments (Terms of Use)

Description Bing Li 2017-11-28 07:25:00 UTC
Description of problem:

If add a VAT number by going back the "Profile" page of step 3 before confirming the subscription, error will occur on step 5 when confirming subscription.

Version-Release number of selected component (if applicable):
Online PROD

How reproducible:
Always

Steps to Reproduce:

1. Sign up a Redhat account;

2. Try to sign up a Pro plan, e.g. EU West (Ireland)

3. Save profile on step 3 with an EU country, e.g. Germany. But leave the "VAT Identification Number" empty;

4. Fill in a valid card number on step 4 and save;

5. On the confirm page of step 5, I noticed taxes were charged. I wanted to use my VAT number and went back to the step 3: "Profile":

6. Fill in a valid VAT number and save;

7. Click "Keep Existing" on step 4: "Payment Method";

8. On the confirm page of step 5, no tax will be charged. Then click "Confirm Subscription" button.


Actual results:
8. Error page will occur after clicking "Confirm Subscription" button. But I was charged actually for the Pro plan, and I can't log in openshift web console. 

The error page shows:
-------------------
We're sorry, but something went wrong.

If the problem persists, reach out to us at help.openshift.com.
-------------------

Expected results:
8. Subscription should be confirmed normally.

Additional info:
Can't reproduce this issue on online-int.

Comment 1 Bing Li 2017-11-28 07:49:31 UTC
Sorry, I made a mistake. This error was caused because of no enough money in my card (Payment was charged in EUR not USD).

Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.